summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthew Waters <matthew@centricular.com>2014-12-18 17:00:30 +1100
committerMatthew Waters <matthew@centricular.com>2015-06-11 22:01:03 +1000
commit23fb666dd745b0fb6a9fb936b6e735c35e9cfd6a (patch)
tree583f76beeef068c617f2eaf1602a4652d8cef97f /configure.ac
parent898b43621982175baba86fd02eadccf3af6c1091 (diff)
downloadgstreamer-plugins-bad-23fb666dd745b0fb6a9fb936b6e735c35e9cfd6a.tar.gz
Implement gtk sinks
two sinks are provided. gtksink which is a cairo/software based renderer and gtkglsink which utilises the GL support in gtk and gstreamer.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d36744004..1f81a5f8b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2585,6 +2585,27 @@ AG_GST_CHECK_FEATURE(GL, [gl elements], gl, [
fi
])
+dnl *** gtk+ ***
+HAVE_GTK3_GL="no"
+translit(dnm, m, l) AM_CONDITIONAL(USE_GTK3, true)
+AG_GST_CHECK_FEATURE(GTK3, [Gtk+ elements], gtk, [
+ PKG_CHECK_MODULES(GTK3, gtk+-3.0, [
+ AC_DEFINE([HAVE_GTK3], 1, [Define if Gtk+ 3.0 is installed])
+ HAVE_GTK3="yes"
+ ], [
+ HAVE_GTK3="no"
+ ])
+ PKG_CHECK_MODULES(GTK3_GL, gtk+-3.0 >= 3.15.0, [
+ AC_DEFINE([HAVE_GTK3_GL], 1, [Define if Gtk+ 3.0 GL is installed])
+ if test "x$HAVE_GL" = "xyes"; then
+ HAVE_GTK3_GL="yes"
+ fi
+ ], [
+ HAVE_GTK3_GL="no"
+ ])
+])
+AM_CONDITIONAL(USE_GTK3_GL, test "x$HAVE_GTK3_GL" = "xyes")
+
dnl *** libvisual ***
translit(dnm, m, l) AM_CONDITIONAL(USE_LIBVISUAL, true)
AG_GST_CHECK_FEATURE(LIBVISUAL, [libvisual visualization library], libvisual, [
@@ -2989,6 +3010,8 @@ AM_CONDITIONAL(USE_FLITE, false)
AM_CONDITIONAL(USE_FLUIDSYNTH, false)
AM_CONDITIONAL(USE_GL, false)
AM_CONDITIONAL(USE_GSM, false)
+AM_CONDITIONAL(USE_GTK3, false)
+AM_CONDITIONAL(USE_GTK3_GL, false)
AM_CONDITIONAL(USE_HLS, false)
AM_CONDITIONAL(USE_KATE, false)
AM_CONDITIONAL(USE_TIGER, false)
@@ -3268,6 +3291,7 @@ tests/examples/gl/gtk/fxtest/Makefile
tests/examples/gl/gtk/switchvideooverlay/Makefile
tests/examples/gl/qt/Makefile
tests/examples/gl/sdl/Makefile
+tests/examples/gtk/Makefile
tests/examples/mpegts/Makefile
tests/examples/mxf/Makefile
tests/examples/opencv/Makefile
@@ -3288,6 +3312,7 @@ ext/wayland/Makefile
ext/daala/Makefile
ext/dts/Makefile
ext/gl/Makefile
+ext/gtk/Makefile
ext/faac/Makefile
ext/faad/Makefile
ext/flite/Makefile