summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKoop Mast <kwm@rainbow-runner.nl>2015-08-21 20:29:24 +0200
committerSebastian Dröge <sebastian@centricular.com>2015-08-22 10:26:47 +0300
commit98457cb6ea7fc22834603546baef07264bffa296 (patch)
treec37295a580cfa36ee73aec05349d2994c8e10733 /configure.ac
parent4a9703b434de3d04b4fb523a8814b9eb2a8ca989 (diff)
downloadgstreamer-plugins-bad-98457cb6ea7fc22834603546baef07264bffa296.tar.gz
curl: Give netinet/ip.h it own configure check
On FreeBSD netinet/ip.h needs the sys/types.h and netinet/in.h header before it can be tested. https://bugzilla.gnome.org/show_bug.cgi?id=753944
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2ba930d81..d8d010912 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1824,9 +1824,17 @@ translit(dnm, m, l) AM_CONDITIONAL(USE_CURL, true)
AG_GST_CHECK_FEATURE(CURL, [Curl plugin], curl, [
PKG_CHECK_MODULES(CURL, libcurl >= 7.35.0, [
HAVE_CURL="yes"
- AC_CHECK_HEADERS([unistd.h sys/socket.h sys/types.h netinet/in.h netinet/ip.h netinet/tcp.h fcntl.h], [ ], [
+ AC_CHECK_HEADERS([unistd.h sys/socket.h sys/types.h netinet/in.h netinet/tcp.h fcntl.h], [ ], [
AC_CHECK_HEADERS([unistd.h sys/types.h winsock2.h ws2tcpip.h fcntl.h], [ ], [HAVE_CURL="no"])
])
+ AC_CHECK_HEADERS([netinet/ip.h], [], [HAVE_CURL="no"],
+ [[#ifdef HAVE_SYS_TYPES_H
+ # include <sys/types.h>
+ #endif
+ #ifdef HAVE_NETINET_IN_H
+ # include <netinet/in.h>
+ #endif
+ ]])
AC_MSG_CHECKING([for socket support needed by curlsink])
AC_MSG_RESULT($HAVE_CURL)
], [