summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthew Waters <matthew@centricular.com>2015-01-20 22:01:39 +1100
committerMatthew Waters <matthew@centricular.com>2015-01-22 21:29:52 +1100
commite10d2417e2fe7aa4733c076984339b0d61caa169 (patch)
tree7823ca52c593f572c51eecf60f54350e5d255a98 /configure.ac
parentfe8fdbdc7cbedba7a2c408c9b0d17fdea520642f (diff)
downloadgstreamer-plugins-bad-e10d2417e2fe7aa4733c076984339b0d61caa169.tar.gz
gl/cocoa: move to CGL and CAOpenGLLayer for rendering
Removes the use of NSOpenGL* variety and functions. Any Cocoa specific functions that took/returned a NSOpenGL* object now take/return the CGL equivalents.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 976f74fe5..da0ebb496 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1007,7 +1007,7 @@ case $host in
fi
if test "x$NEED_COCOA" != "xno"; then
- GL_LIBS="$LIBS -framework OpenGL -framework Cocoa"
+ GL_LIBS="$LIBS -framework OpenGL -framework Cocoa -framework QuartzCore -framework CoreFoundation"
GL_CFLAGS="$GL_CFLAGS"
USE_COCOA=yes
HAVE_WINDOW_COCOA=yes