summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNicolas Dufresne <nicolas.dufresne@collabora.com>2018-08-02 11:19:07 -0400
committerNicolas Dufresne <nicolas.dufresne@collabora.com>2018-08-02 11:31:34 -0400
commitd2ee9b16fa7d4d3c2ded648a7606152209813a34 (patch)
tree8db3c434753e8850b87075660d7bdeb1393a74eb /configure.ac
parent9c91282ba64d1750c9c1500b06f826d565ace859 (diff)
downloadgstreamer-plugins-bad-d2ee9b16fa7d4d3c2ded648a7606152209813a34.tar.gz
opencv: Fixup include to follow new standard
This uses the new path for OpenCV headers. OpenCV now have master headers files per modules, which reduce the amount of required includes. Note that HIGHGUI was included to get the imgcodecs includes, which I fixed, though the master header is missing the C headers, so I included that directly. All the image stuff should be ported to C++ eventually. Finally, this patch also update the header checks to reflect the modules that are really being used.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 8 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index db1f3cb7d..36b3a548b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1891,13 +1891,14 @@ AG_GST_CHECK_FEATURE(OPENCV, [opencv plugins], opencv, [
OLD_CPPFLAGS=$CPPFLAGS
CPPFLAGS=$OPENCV_CFLAGS
something_not_found=no
- AC_CHECK_HEADERS([opencv2/core/core_c.h \
- opencv2/core/version.hpp \
- opencv2/highgui/highgui_c.h \
- opencv2/imgproc/imgproc.hpp \
- opencv2/imgproc/imgproc_c.h \
- opencv2/objdetect/objdetect.hpp \
- opencv2/video/background_segm.hpp \
+ AC_CHECK_HEADERS([opencv2/bgsegm.hpp \
+ opencv2/calib3d.hpp \
+ opencv2/core.hpp \
+ opencv2/imgcodecs/imgcodecs_c.h \
+ opencv2/imgproc.hpp \
+ opencv2/objdetect.hpp \
+ opencv2/opencv.hpp \
+ opencv2/video.hpp \
opencv2/bgsegm.hpp], [], [something_not_found=yes])
CPPFLAGS=$OLD_CPPFLAGS