summaryrefslogtreecommitdiff
path: root/docs/plugins/Makefile.am
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim.muller@collabora.co.uk>2010-05-31 00:33:16 +0100
committerTim-Philipp Müller <tim.muller@collabora.co.uk>2010-05-31 00:33:16 +0100
commitfd37286ad0498c7b6e031713360b0eba8f9eb039 (patch)
tree48b875d77627cb3465da65409649800a4a06b838 /docs/plugins/Makefile.am
parente9c48d1671ec4d192ecd2fd8cb784655b91a21bd (diff)
downloadgstreamer-plugins-bad-fd37286ad0498c7b6e031713360b0eba8f9eb039.tar.gz
docs: fix build of gtk-doc scanner
Diffstat (limited to 'docs/plugins/Makefile.am')
-rw-r--r--docs/plugins/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/docs/plugins/Makefile.am b/docs/plugins/Makefile.am
index a454ae370..41a8e1bd0 100644
--- a/docs/plugins/Makefile.am
+++ b/docs/plugins/Makefile.am
@@ -65,7 +65,8 @@ CFILE_GLOB=$(DOC_SOURCE_DIR)/*/*/*.c $(DOC_SOURCE_DIR)/*/*/*.cc
# thomasvs: another nice wingo addition would be an explanation on why
# this is useful ;)
-SCANOBJ_DEPS =
+SCANOBJ_DEPS = \
+ $(top_builddir)/gst-libs/gst/interfaces/libgstphotography-@GST_MAJORMINOR@.la
# Header files to ignore when scanning.
IGNORE_HFILES =
@@ -179,7 +180,7 @@ extra_files =
# CFLAGS and LDFLAGS for compiling scan program. Only needed if your app/lib
# contains GtkObjects/GObjects and you want to document signals and properties.
-GTKDOC_CFLAGS = $(GST_BASE_CFLAGS) -I$(top_builddir)
+GTKDOC_CFLAGS = -DGST_USE_UNSTABLE_API $(GST_PLUGINS_BAD_CFLAGS) $(GST_BASE_CFLAGS) -I$(top_builddir)
GTKDOC_LIBS = $(SCANOBJ_DEPS) $(GST_BASE_LIBS)
GTKDOC_CC=$(LIBTOOL) --tag=CC --mode=compile $(CC)