summaryrefslogtreecommitdiff
path: root/docs/plugins/Makefile.am
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim.muller@collabora.co.uk>2010-05-26 14:03:20 +0100
committerTim-Philipp Müller <tim.muller@collabora.co.uk>2010-05-26 14:06:11 +0100
commit0f70a6b885fbc90e2413aa0e7f1b08e0cef45379 (patch)
tree2730bc4b5865e2e8816284ee90e9e5fb82aa5244 /docs/plugins/Makefile.am
parentd1b800a4cec18c9db5b6c765c037359f22cdbda8 (diff)
downloadgstreamer-plugins-bad-0f70a6b885fbc90e2413aa0e7f1b08e0cef45379.tar.gz
docs: fix dist/distcheck issues with camerabin figures
Move figures into docs/plugins as well, to avoid issues with make dist and make distcheck (make distdir will not first descend into child directories). Out-of-source build seems to still work as well.
Diffstat (limited to 'docs/plugins/Makefile.am')
-rw-r--r--docs/plugins/Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/docs/plugins/Makefile.am b/docs/plugins/Makefile.am
index da7b441ef..a454ae370 100644
--- a/docs/plugins/Makefile.am
+++ b/docs/plugins/Makefile.am
@@ -169,7 +169,7 @@ EXTRA_HFILES = \
$(top_srcdir)/gst-libs/gst/interfaces/photography.h
# Images to copy into HTML directory.
-HTML_IMAGES = figures/*.png
+HTML_IMAGES = camerabin.png
# Extra SGML files that are included by $(DOC_MAIN_SGML_FILE).
content_files =
@@ -192,4 +192,14 @@ DOC_OVERRIDES =
include $(top_srcdir)/common/gtk-doc-plugins.mak
-SUBDIRS = figures
+SUBDIRS =
+
+FIGURES_SOURCEFILES = camerabin.dot
+FIGURES_IMAGES = camerabin.png
+
+EXTRA_DIST += $(FIGURES_SOURCEFILES)
+
+.dot.png:
+ dot -Tpng $< -o$@
+
+update-figures: $(FIGURES_IMAGES)