summaryrefslogtreecommitdiff
path: root/ext/Makefile.am
diff options
context:
space:
mode:
authorSebastian Dröge <sebastian@centricular.com>2014-10-03 13:45:26 +0300
committerSebastian Dröge <sebastian@centricular.com>2014-10-03 17:23:35 +0300
commitcf4ec9b04e1ada5532e9ad0d8d14ad7f5ea01d5c (patch)
tree2e647bbaa6c67a6c910bfdf7e6f2b5fead64e204 /ext/Makefile.am
parent3637296ee92da455a08301fbb168cb69dacc9d58 (diff)
downloadgstreamer-plugins-bad-cf4ec9b04e1ada5532e9ad0d8d14ad7f5ea01d5c.tar.gz
openh264: Add OpenH264 based encoder/decoder elements
These are the openh264 elements released under the BSD-2 license by Ericsson as part of the OpenWebRTC project. https://github.com/EricssonResearch/openwebrtc-gst-plugins https://bugzilla.gnome.org/show_bug.cgi?id=737788
Diffstat (limited to 'ext/Makefile.am')
-rw-r--r--ext/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/ext/Makefile.am b/ext/Makefile.am
index 5701057fb..f39e1ee70 100644
--- a/ext/Makefile.am
+++ b/ext/Makefile.am
@@ -238,6 +238,12 @@ else
OPENEXR_DIR =
endif
+if USE_OPENH264
+OPENH264_DIR = openh264
+else
+OPENH264_DIR =
+endif
+
if USE_OPENNI2
OPENNI2_DIR=openni2
else
@@ -437,6 +443,7 @@ SUBDIRS=\
$(OPENAL_DIR) \
$(OPENCV_DIR) \
$(OPENEXR_DIR) \
+ $(OPENH264_DIR) \
$(OPENJPEG_DIR) \
$(OPENNI2_DIR) \
$(OPUS_DIR) \
@@ -499,6 +506,7 @@ DIST_SUBDIRS = \
openal \
opencv \
openexr \
+ openh264 \
openni2 \
openjpeg \
opus \