summaryrefslogtreecommitdiff
path: root/ext/Makefile.am
diff options
context:
space:
mode:
authorChris Bass <floobleflam@gmail.com>2016-06-29 09:58:38 +0100
committerSebastian Dröge <sebastian@centricular.com>2016-11-01 20:46:46 +0200
commitd82ae6949feb100b74ca3781a57cbe19ce38787c (patch)
tree95943453fcebb31a768757f296defcf2a6ab243c /ext/Makefile.am
parent280b4ac2ffc63908a74944f50589b2630be16232 (diff)
downloadgstreamer-plugins-bad-d82ae6949feb100b74ca3781a57cbe19ce38787c.tar.gz
ttml: Add plugin that supports TTML subtitles
Add a parser (ttmlparse) and renderer (ttmlrender) element that handle subtitles that use the EBU-TT-D profile of TTML1. https://bugzilla.gnome.org/show_bug.cgi?id=758232
Diffstat (limited to 'ext/Makefile.am')
-rw-r--r--ext/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/ext/Makefile.am b/ext/Makefile.am
index bae25c2bd..16821e0be 100644
--- a/ext/Makefile.am
+++ b/ext/Makefile.am
@@ -424,6 +424,12 @@ else
WEBRTCDSP_DIR=
endif
+if USE_TTML
+TTML_DIR=ttml
+else
+TTML_DIR=
+endif
+
SUBDIRS=\
$(VOAACENC_DIR) \
$(ASSRENDER_DIR) \
@@ -495,7 +501,8 @@ SUBDIRS=\
$(X265_DIR) \
$(DTLS_DIR) \
$(VULKAN_DIR) \
- $(WEBRTCDSP_DIR)
+ $(WEBRTCDSP_DIR) \
+ $(TTML_DIR)
DIST_SUBDIRS = \
assrender \
@@ -565,6 +572,7 @@ DIST_SUBDIRS = \
x265 \
dtls \
vulkan \
- webrtcdsp
+ webrtcdsp \
+ ttml
include $(top_srcdir)/common/parallel-subdirs.mak