summaryrefslogtreecommitdiff
path: root/ext/dash/Makefile.am
diff options
context:
space:
mode:
authorMatthieu Bouron <matthieu.bouron@collabora.com>2014-06-25 15:55:32 +0200
committerThiago Santos <thiagoss@osg.samsung.com>2014-08-19 15:34:01 -0300
commit82fdb3aefcd2d2b642b97ced2d0475b39114a5ba (patch)
treef45cf47b293881959b41ea865e38b303eaf7987c /ext/dash/Makefile.am
parentcb4fd36e7eb6c8331542a3eb9c040e6df400f068 (diff)
downloadgstreamer-plugins-bad-82fdb3aefcd2d2b642b97ced2d0475b39114a5ba.tar.gz
dashdemux: push language code tag
Language code tag is retrieved from the AdaptationSet language property. https://bugzilla.gnome.org/show_bug.cgi?id=732237
Diffstat (limited to 'ext/dash/Makefile.am')
-rw-r--r--ext/dash/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/ext/dash/Makefile.am b/ext/dash/Makefile.am
index 97d8623ec..32964bb15 100644
--- a/ext/dash/Makefile.am
+++ b/ext/dash/Makefile.am
@@ -13,10 +13,18 @@ noinst_HEADERS = \
gstdash_debug.h
# compiler and linker flags used to compile this plugin, set in configure.ac
-libgstdashdemux_la_CFLAGS = $(GST_PLUGINS_BAD_CFLAGS) $(GST_CFLAGS) $(LIBXML2_CFLAGS)
+libgstdashdemux_la_CFLAGS = \
+ $(GST_PLUGINS_BAD_CFLAGS) \
+ $(GST_PLUGINS_BASE_CFLAGS) \
+ $(GST_BASE_CFLAGS) \
+ $(GST_CFLAGS) \
+ $(LIBXML2_CFLAGS)
libgstdashdemux_la_LIBADD = \
$(top_builddir)/gst-libs/gst/uridownloader/libgsturidownloader-@GST_API_VERSION@.la \
- $(GST_LIBS) $(GST_BASE_LIBS) $(LIBXML2_LIBS)
+ -lgsttag-$(GST_API_VERSION) \
+ $(GST_BASE_LIBS) \
+ $(GST_LIBS) \
+ $(LIBXML2_LIBS)
libgstdashdemux_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
libgstdashdemux_la_LIBTOOLFLAGS = --tag=disable-static