summaryrefslogtreecommitdiff
path: root/ext/openal/Makefile.am
diff options
context:
space:
mode:
authorSebastian Dröge <sebastian.droege@collabora.co.uk>2011-05-23 13:41:36 +0200
committerSebastian Dröge <sebastian.droege@collabora.co.uk>2011-05-23 14:30:11 +0200
commit66a4ed47a3e3160d4ff1b93fa47bb27191977137 (patch)
treee97187b561f3b6ef3230ff95482754edc3ab2771 /ext/openal/Makefile.am
parentd25908cf81798b9d510a43160b7fc9dcd3b21397 (diff)
downloadgstreamer-plugins-bad-66a4ed47a3e3160d4ff1b93fa47bb27191977137.tar.gz
openal: Add new OpenAL sink element
Based on a patch by Chris Robinson <chris.kcat@gmail.com> Fixes bug #615615.
Diffstat (limited to 'ext/openal/Makefile.am')
-rw-r--r--ext/openal/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/ext/openal/Makefile.am b/ext/openal/Makefile.am
new file mode 100644
index 000000000..a80e34fff
--- /dev/null
+++ b/ext/openal/Makefile.am
@@ -0,0 +1,15 @@
+# Note: plugindir is set in configure
+
+plugin_LTLIBRARIES = libgstopenal.la
+
+# sources used to compile this plug-in
+libgstopenal_la_SOURCES = gstopenal.c gstopenalsink.c
+
+# compiler and linker flags used to compile this plugin, set in configure.ac
+libgstopenal_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS) $(GST_CFLAGS) $(OPENAL_CFLAGS)
+libgstopenal_la_LIBADD = $(GST_PLUGINS_BASE_LIBS) -lgstaudio-@GST_MAJORMINOR@ $(GST_BASE_LIBS) $(GST_LIBS) $(OPENAL_LIBS)
+libgstopenal_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgstopenal_la_LIBTOOLFLAGS = --tag=disable-static
+
+# headers we need but don't want installed
+noinst_HEADERS = gstopenalsink.h