summaryrefslogtreecommitdiff
path: root/ext/resindvd/Makefile.am
diff options
context:
space:
mode:
authorJan Schmidt <thaytan@noraisin.net>2009-04-01 02:23:20 +0100
committerJan Schmidt <thaytan@noraisin.net>2009-04-02 14:49:39 +0100
commit0cf5e27b5bba04a2a0accebef6ad0ac0eed295e8 (patch)
tree5671b4959d30f5d7c5da7a0078460dd365caa2a5 /ext/resindvd/Makefile.am
parent97a1f14fc0475a10654f1ff411dcc65c5e99b799 (diff)
downloadgstreamer-plugins-bad-0cf5e27b5bba04a2a0accebef6ad0ac0eed295e8.tar.gz
resindvd: Use new GstNavigation functionality.
Handle the new DVD commands, so that we can handle commands from a player to change angle, jump to menus etc. Use the new GstNavigation event parsing functions, instead of hand-rolled stuff. Send GstNavigation notification messages when the mouse enters a button or leaves it, so UI can turn the mouse cursor to a hand icon.
Diffstat (limited to 'ext/resindvd/Makefile.am')
-rw-r--r--ext/resindvd/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/ext/resindvd/Makefile.am b/ext/resindvd/Makefile.am
index 3a00d151e..4e5b87f0f 100644
--- a/ext/resindvd/Makefile.am
+++ b/ext/resindvd/Makefile.am
@@ -17,8 +17,11 @@ libresindvd_la_SOURCES = \
rsnparsetter.c \
rsnwrappedbuffer.c
-libresindvd_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS) $(GST_CFLAGS) $(DVDNAV_CFLAGS)
-libresindvd_la_LIBADD = $(GST_PLUGINS_BASE_CFLAGS) -lgstvideo-$(GST_MAJORMINOR) $(GST_BASE_LIBS) $(GST_LIBS) $(DVDNAV_LIBS)
+libresindvd_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS) \
+$(GST_CFLAGS) $(DVDNAV_CFLAGS)
+libresindvd_la_LIBADD = $(GST_PLUGINS_BASE_CFLAGS) \
+-lgstinterfaces-$(GST_MAJORMINOR) -lgstvideo-$(GST_MAJORMINOR) \
+$(GST_BASE_LIBS) $(GST_LIBS) $(DVDNAV_LIBS)
libresindvd_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
libresindvd_la_LIBTOOLFLAGS = --tag=disable-static