summaryrefslogtreecommitdiff
path: root/ext/srtp/Makefile.am
diff options
context:
space:
mode:
authorEdward Hervey <edward@collabora.com>2013-06-23 09:05:29 +0200
committerEdward Hervey <edward@collabora.com>2013-06-23 09:06:29 +0200
commitf88f1d0a3539331ca7489f181f80fcf76be4d041 (patch)
tree9027dc114a57c6407af5e43d8def8011eaef3c34 /ext/srtp/Makefile.am
parent0592bcc3c90125f8a9a68ee8e8940176b9c8cc97 (diff)
downloadgstreamer-plugins-bad-f88f1d0a3539331ca7489f181f80fcf76be4d041.tar.gz
srtp: Fix dist
The enums should not be dist-ed and instead be re-generated when compiling.
Diffstat (limited to 'ext/srtp/Makefile.am')
-rw-r--r--ext/srtp/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/ext/srtp/Makefile.am b/ext/srtp/Makefile.am
index fa8384375..778db02ee 100644
--- a/ext/srtp/Makefile.am
+++ b/ext/srtp/Makefile.am
@@ -6,9 +6,7 @@ libgstsrtp_la_SOURCES = \
gstsrtpdec.c \
gstsrtpdec.h \
gstsrtpenc.c \
- gstsrtpenc.h \
- gstsrtp-enumtypes.c \
- gstsrtp-enumtypes.h
+ gstsrtpenc.h
libgstsrtp_la_CFLAGS = $(GST_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS) $(SRTP_CFLAGS)
libgstsrtp_la_LIBADD = $(GST_PLUGINS_BASE_LIBS) \
@@ -28,6 +26,8 @@ glib_gen_prefix=gst_srtp
glib_gen_basename=gstsrtp
BUILT_SOURCES = gstsrtp-enumtypes.c gstsrtp-enumtypes.h
+nodist_libgstsrtp_la_SOURCES = $(BUILT_SOURCES)
+
CLEANFILES = $(BUILT_SOURCES)
include $(top_srcdir)/common/gst-glib-gen.mak