summaryrefslogtreecommitdiff
path: root/gst-libs/gst/audio/Makefile.am
diff options
context:
space:
mode:
authorWim Taymans <wim.taymans@gmail.com>2005-03-04 10:16:10 +0000
committerWim Taymans <wim.taymans@gmail.com>2005-03-04 10:16:10 +0000
commit3a4d09d9e5f535634ba2503fbe1da45c39110ce0 (patch)
treed53cd96cabd5d0cf4db6081393daf58ea6496032 /gst-libs/gst/audio/Makefile.am
parente1975c599cfbe5f23e4bd602591e95838afb3c8c (diff)
downloadgstreamer-plugins-bad-3a4d09d9e5f535634ba2503fbe1da45c39110ce0.tar.gz
More work on subclassing the sinks from the basesink.BRANCH-THREADED
Original commit message from CVS: More work on subclassing the sinks from the basesink. First attempt at generic audiosink base objects. Make oss DMA audiosink.
Diffstat (limited to 'gst-libs/gst/audio/Makefile.am')
-rw-r--r--gst-libs/gst/audio/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/gst-libs/gst/audio/Makefile.am b/gst-libs/gst/audio/Makefile.am
index 99089947e..9bf04c2c2 100644
--- a/gst-libs/gst/audio/Makefile.am
+++ b/gst-libs/gst/audio/Makefile.am
@@ -17,7 +17,9 @@ CLEANFILES = gstaudiofilterexample.c \
$(BUILT_SOURCES)
libgstaudio_la_SOURCES = audio.c audioclock.c \
- multichannel.c
+ multichannel.c \
+ gstbaseaudiosink.c \
+ gstringbuffer.c
nodist_libgstaudio_la_SOURCES = $(built_sources)
libgstaudioincludedir = $(includedir)/gstreamer-@GST_MAJORMINOR@/gst/audio
@@ -25,6 +27,8 @@ libgstaudioinclude_HEADERS = \
audio.h \
audioclock.h \
gstaudiofilter.h \
+ gstbaseaudiosink.h \
+ gstringbuffer.h \
multichannel.h \
multichannel-enumtypes.h