summaryrefslogtreecommitdiff
path: root/gst-libs/gst/gl/eagl/Makefile.am
diff options
context:
space:
mode:
authorSebastian Dröge <sebastian@centricular.com>2014-04-12 21:43:50 +0200
committerSebastian Dröge <sebastian@centricular.com>2014-04-12 22:25:13 +0200
commitae81268565e79c7088a9fda6a10b8650b44e3643 (patch)
tree0ba5d9f73eb2f98d2618f6e323fbd6f427dae9f2 /gst-libs/gst/gl/eagl/Makefile.am
parent6b2c24d0c48c395c8aee4ce7e2823d30944aac00 (diff)
downloadgstreamer-plugins-bad-ae81268565e79c7088a9fda6a10b8650b44e3643.tar.gz
gl: Add support for iOS EAGL platform
https://bugzilla.gnome.org/show_bug.cgi?id=703341
Diffstat (limited to 'gst-libs/gst/gl/eagl/Makefile.am')
-rw-r--r--gst-libs/gst/gl/eagl/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/gst-libs/gst/gl/eagl/Makefile.am b/gst-libs/gst/gl/eagl/Makefile.am
new file mode 100644
index 000000000..03ef61f61
--- /dev/null
+++ b/gst-libs/gst/gl/eagl/Makefile.am
@@ -0,0 +1,34 @@
+## Process this file with automake to produce Makefile.in
+
+noinst_LTLIBRARIES = libgstgl-eagl.la
+
+libgstgl_eagl_la_SOURCES = \
+ gstglwindow_eagl.m \
+ gstglcontext_eagl.m
+
+noinst_HEADERS = \
+ gstglwindow_eagl.h \
+ gstglcontext_eagl.h
+
+libgstgl_eagl_la_CFLAGS = \
+ -I$(top_srcdir)/gst-libs \
+ -I$(top_builddir)/gst-libs \
+ $(GL_CFLAGS) \
+ $(GST_PLUGINS_BASE_CFLAGS) \
+ $(GST_BASE_CFLAGS) \
+ $(GST_CFLAGS)
+
+libgstgl_eagl_la_OBJCFLAGS = \
+ -I$(top_srcdir)/gst-libs \
+ -I$(top_builddir)/gst-libs \
+ $(GL_CFLAGS) \
+ $(GL_OBJCFLAGS) \
+ $(GST_PLUGINS_BASE_CFLAGS) \
+ $(GST_BASE_CFLAGS) \
+ $(GST_CFLAGS)
+
+libgstgl_eagl_la_LDFLAGS = \
+ $(GST_LIB_LDFLAGS) \
+ $(GST_ALL_LDFLAGS)
+
+libgstgl_eagl_la_LIBTOOLFLAGS = $(GST_PLUGIN_LIBTOOLFLAGS) --tag=CC