summaryrefslogtreecommitdiff
path: root/gst-libs/gst/mpegts/Makefile.am
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2016-01-19 08:39:58 +0000
committerTim-Philipp Müller <tim@centricular.com>2016-04-06 14:38:04 +0100
commit2e896086f2eff0fa7fd8fa1f2fd87c60029f390f (patch)
tree5c047cce698a1f9053a65cac88887aafbcb33d6d /gst-libs/gst/mpegts/Makefile.am
parentf5cdddb5d620adb5f0a908b9e37b8127f9a2fe61 (diff)
downloadgstreamer-plugins-bad-2e896086f2eff0fa7fd8fa1f2fd87c60029f390f.tar.gz
libs: g-i: fix init section to avoid compiler warnings
..GstPlayer-1.0.c: In function ‘main’: ..GstPlayer-1.0.c:587:3: warning: implicit declaration of function ‘gst_init’ https://bugzilla.gnome.org/show_bug.cgi?id=760090
Diffstat (limited to 'gst-libs/gst/mpegts/Makefile.am')
-rw-r--r--gst-libs/gst/mpegts/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/gst-libs/gst/mpegts/Makefile.am b/gst-libs/gst/mpegts/Makefile.am
index 2511d49f6..cd8b8ad40 100644
--- a/gst-libs/gst/mpegts/Makefile.am
+++ b/gst-libs/gst/mpegts/Makefile.am
@@ -82,7 +82,7 @@ GstMpegts-@GST_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libgstmpegts-@GST_API_
--pkg gstreamer-@GST_API_VERSION@ \
--pkg gstreamer-video-@GST_API_VERSION@ \
--pkg-export gstreamer-mpegts-@GST_API_VERSION@ \
- --add-init-section="gst_init(NULL,NULL);" \
+ --add-init-section="$(INTROSPECTION_INIT)" \
-DGST_USE_UNSTABLE_API \
--output $@ \
$(gir_headers) \