summaryrefslogtreecommitdiff
path: root/gst/audiomixer/Makefile.am
diff options
context:
space:
mode:
authorSebastian Dröge <sebastian@centricular.com>2013-11-06 15:18:50 +0100
committerSebastian Dröge <sebastian@centricular.com>2013-11-06 15:35:38 +0100
commitcaeaade7008b9716e4801afeb8a37d9ed240ccaf (patch)
tree49f13d294553e811f0a6fc8a8d475fdb9abb2053 /gst/audiomixer/Makefile.am
parent30ed37657bf039a7b96f5e746fb06c15cb76046c (diff)
downloadgstreamer-plugins-bad-caeaade7008b9716e4801afeb8a37d9ed240ccaf.tar.gz
audiomixer: Add new element based on adder that does synchronized audio mixing
Diffstat (limited to 'gst/audiomixer/Makefile.am')
-rw-r--r--gst/audiomixer/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/gst/audiomixer/Makefile.am b/gst/audiomixer/Makefile.am
new file mode 100644
index 000000000..90328bc92
--- /dev/null
+++ b/gst/audiomixer/Makefile.am
@@ -0,0 +1,18 @@
+plugin_LTLIBRARIES = libgstaudiomixer.la
+
+ORC_SOURCE=gstaudiomixerorc
+include $(top_srcdir)/common/orc.mak
+
+
+libgstaudiomixer_la_SOURCES = gstaudiomixer.c
+nodist_libgstaudiomixer_la_SOURCES = $(ORC_NODIST_SOURCES)
+libgstaudiomixer_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS) $(GST_CFLAGS) $(ORC_CFLAGS)
+libgstaudiomixer_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgstaudiomixer_la_LIBADD = \
+ $(GST_PLUGINS_BASE_LIBS) \
+ -lgstaudio-@GST_API_VERSION@ \
+ $(GST_BASE_LIBS) $(GST_LIBS) $(ORC_LIBS)
+libgstaudiomixer_la_LIBTOOLFLAGS = $(GST_PLUGIN_LIBTOOLFLAGS)
+
+noinst_HEADERS = gstaudiomixer.h
+