summaryrefslogtreecommitdiff
path: root/gst/coloreffects/Makefile.am
diff options
context:
space:
mode:
authorFilippo Argiolas <filippo.argiolas@gmail.com>2010-08-01 23:03:24 +0200
committerSebastian Dröge <sebastian.droege@collabora.co.uk>2010-08-04 10:04:20 +0200
commit79c343badee269afc423a2c08e99de97eeeb1c0b (patch)
tree70321c30052667548ea6cc84ca23be893736de79 /gst/coloreffects/Makefile.am
parent76b4ed4ef1b2067d62dddfb7dfbe75a16c0ae0ad (diff)
downloadgstreamer-plugins-bad-79c343badee269afc423a2c08e99de97eeeb1c0b.tar.gz
coloreffects: new plugin for lookup table color mapping
Implements a color lookup table filter with 4 presets: - heat: fake heat camera effect - sepia: sepia toning - xray: invert + shade to blue - xpro: cross process https://bugzilla.gnome.org/show_bug.cgi?id=625817
Diffstat (limited to 'gst/coloreffects/Makefile.am')
-rw-r--r--gst/coloreffects/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/gst/coloreffects/Makefile.am b/gst/coloreffects/Makefile.am
new file mode 100644
index 000000000..331526115
--- /dev/null
+++ b/gst/coloreffects/Makefile.am
@@ -0,0 +1,16 @@
+plugin_LTLIBRARIES = libgstcoloreffects.la
+
+libgstcoloreffects_la_SOURCES = \
+ gstplugin.c \
+ gstcoloreffects.c
+libgstcoloreffects_la_CFLAGS = \
+ $(GST_PLUGINS_BASE_CFLAGS) \
+ $(GST_CFLAGS)
+libgstcoloreffects_la_LIBADD = \
+ $(GST_PLUGINS_BASE_LIBS) -lgstvideo-@GST_MAJORMINOR@ \
+ $(GST_BASE_LIBS) \
+ $(GST_LIBS)
+libgstcoloreffects_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgstcoloreffects_la_LIBTOOLFLAGS = --tag=disable-static
+
+noinst_HEADERS = gstcoloreffects.h