summaryrefslogtreecommitdiff
path: root/gst/nuvdemux/Makefile.am
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2010-05-19 17:12:55 -0700
committerDavid Schleef <ds@schleef.org>2010-05-19 18:24:02 -0700
commitc3d497776187243ffe96d36f7632817dfaf7e852 (patch)
treef9f15fec844c37ab66338ca45779c348f7c58fe1 /gst/nuvdemux/Makefile.am
parente3925075f95e7afcf6b1787df618da70f1460494 (diff)
downloadgstreamer-plugins-bad-c3d497776187243ffe96d36f7632817dfaf7e852.tar.gz
Split out GST_PLUGINS_BAD_CFLAGS from GST_CFLAGS
Move include directives for gst-libs into GST_PLUGINS_BAD_CFLAGS, and fix all the Makefiles that use it. This is so that all the include directories are added in the proper order: first the directories in srcdir/builddir, then gst-plugins-base dirs, then gstreamer dirs. If the order is wrong, installed headers may be used instead of local headers and/or uninstalled headers from -base.
Diffstat (limited to 'gst/nuvdemux/Makefile.am')
-rw-r--r--gst/nuvdemux/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/gst/nuvdemux/Makefile.am b/gst/nuvdemux/Makefile.am
index ef19fb63a..e51156858 100644
--- a/gst/nuvdemux/Makefile.am
+++ b/gst/nuvdemux/Makefile.am
@@ -1,9 +1,9 @@
plugin_LTLIBRARIES = libgstnuvdemux.la
-libgstnuvdemux_la_CFLAGS = ${GST_CFLAGS}
+libgstnuvdemux_la_CFLAGS = $(GST_PLUGINS_BAD_CFLAGS) $(GST_CFLAGS)
libgstnuvdemux_la_LIBADD = $(GST_BASE_LIBS)
-libgstnuvdemux_la_LDFLAGS = ${GST_PLUGIN_LDFLAGS}
+libgstnuvdemux_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
libgstnuvdemux_la_SOURCES = gstnuvdemux.c
libgstnuvdemux_la_LIBTOOLFLAGS = --tag=disable-static