summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@centricular.com>2016-11-29 01:41:28 +0530
committerNirbheek Chauhan <nirbheek@centricular.com>2016-11-29 02:00:52 +0530
commit2160e0e2bd801c81d79323343396fc156f560c75 (patch)
tree6d955ebb2840536795c3ab310993f1701d86e2ba /meson.build
parent57bb47f3f79b9814e77b1da0f84cf50b7f1c1732 (diff)
downloadgstreamer-plugins-bad-2160e0e2bd801c81d79323343396fc156f560c75.tar.gz
meson: Rework opencv plugin checks
a) Use get_pkgconfig_variable() to get the opencv prefix b) Place an upper limit on the opencv version c) Ensure that headers are available (b) and (c) just copy what the configure.ac checks do.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index eecd37cfa..178826763 100644
--- a/meson.build
+++ b/meson.build
@@ -27,6 +27,7 @@ libversion = '@0@.@1@.0'.format(soversion, gst_version_minor.to_int() * 100 + gs
plugins_install_dir = '@0@/gstreamer-1.0'.format(get_option('libdir'))
cc = meson.get_compiler('c')
+cxx = meson.get_compiler('cpp')
if cc.get_id() == 'msvc'
# Ignore several spurious warnings for things gstreamer does very commonly