summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThibault Saunier <thibault.saunier@osg.samsung.com>2016-09-30 11:35:41 -0300
committerThibault Saunier <thibault.saunier@osg.samsung.com>2016-09-30 11:38:24 -0300
commit712c1b3c6886b416672749964f4ffdda879a4d4c (patch)
treeaefcb44ef3e38202b21e81ac957fc28dd3f7e665 /meson.build
parentdd118c4737a41a45e6f2d6ffbf5783a6b9c7fee3 (diff)
downloadgstreamer-plugins-bad-712c1b3c6886b416672749964f4ffdda879a4d4c.tar.gz
meson: Setup pre-commit hooks when configuring
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 883c1fd52..e857b1ba5 100644
--- a/meson.build
+++ b/meson.build
@@ -350,3 +350,6 @@ subdir('gst')
subdir('sys')
subdir('ext')
subdir('pkgconfig')
+
+python3 = find_program('python3')
+run_command(python3, '-c', 'import shutil; shutil.copy("hooks/pre-commit.hook", ".git/hooks/pre-commit")')