summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMatthew Waters <matthew@centricular.com>2016-11-17 15:15:18 +1100
committerMatthew Waters <matthew@centricular.com>2016-11-17 15:16:18 +1100
commitb69dadcc61683e151a2baeea22f7088ef024039e (patch)
tree2a8a22215a68df1c26c18202fef8a98ba23333d1 /meson.build
parent39b59beace94549c63ccb71a09eaef3fd907a83a (diff)
downloadgstreamer-plugins-bad-b69dadcc61683e151a2baeea22f7088ef024039e.tar.gz
meson: wayland: move dep checks to the lib
Moves them closer to where they are used. We don't want every check in the main meson.build file.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 0 insertions, 10 deletions
diff --git a/meson.build b/meson.build
index 4c7bac867..04ba44180 100644
--- a/meson.build
+++ b/meson.build
@@ -331,16 +331,6 @@ else
cdata.set('DISABLE_ORC', 1)
endif
-# Wayland checks
-
-wl_req = '>= 1.4'
-wl_client_dep = dependency('wayland-client', version: wl_req, required: false)
-libdrm_dep = dependency('libdrm', version: '>= 2.4.55', required: false)
-wl_protocol_dep = dependency('wayland-protocols', version: wl_req,
- required: false)
-wl_scanner = find_program('wayland-scanner')
-use_wayland = wl_protocol_dep.found() and wl_client_dep.found() and wl_scanner.found() and libdrm_dep.found()
-
configure_file(input : 'config.h.meson',
output : 'config.h',
configuration : cdata)