summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorScott D Phillips <scott.d.phillips@intel.com>2017-05-08 11:01:39 -0700
committerSebastian Dröge <sebastian@centricular.com>2017-05-08 22:08:05 +0200
commitc66107991f43687358a4eec1b84167034dcad83e (patch)
tree9ac7951f96f51ac31c03afda18409dc2dc11668f /meson.build
parent216f044e88fcbcda788072e279b5e05f532a38f5 (diff)
downloadgstreamer-plugins-bad-c66107991f43687358a4eec1b84167034dcad83e.tar.gz
meson: Ignore msvc warnings in C++ as well
We were only ignoring the listed msvc warnings for C language files and not C++. This was working by the coincidence that we did not have any instances of these warnings in C++ files. Lately the build of decklink has been fixed on windows, and it has an instance of one of these warnings in a C++ file. https://bugzilla.gnome.org/show_bug.cgi?id=782345
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 52f0dd6d7..a7bb42b36 100644
--- a/meson.build
+++ b/meson.build
@@ -34,12 +34,14 @@ if cc.get_id() == 'msvc'
# If a warning is completely useless and spammy, use '/wdXXXX' to suppress it
# If a warning is harmless but hard to fix, use '/woXXXX' so it's shown once
# NOTE: Only add warnings here if you are sure they're spurious
- add_project_arguments(
+ msvc_args = [
'/wd4018', # implicit signed/unsigned conversion
'/wd4146', # unary minus on unsigned (beware INT_MIN)
'/wd4244', # lossy type conversion (e.g. double -> int)
'/wd4305', # truncating type conversion (e.g. double -> float)
- language : 'c')
+ ]
+ add_project_arguments(msvc_args, language : 'c')
+ add_project_arguments(msvc_args, language : 'cpp')
# Disable SAFESEH with MSVC for plugins and libs that use external deps that
# are built with MinGW
noseh_link_args = ['/SAFESEH:NO']