summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2017-12-19 17:34:50 +0000
committerTim-Philipp Müller <tim@centricular.com>2017-12-19 17:34:50 +0000
commit27e1e515a4666736397da161ce47a34112fd4a26 (patch)
tree0da34713d015561132bcb0d6cfb1724c6d0dbd14 /meson.build
parentb680870c32f8b2faaaa942ec316806631b5fdeab (diff)
downloadgstreamer-plugins-bad-27e1e515a4666736397da161ce47a34112fd4a26.tar.gz
meson: gl: fix build of openglmixers plugin
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build19
1 files changed, 13 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index 646234c21..4dca0ed54 100644
--- a/meson.build
+++ b/meson.build
@@ -331,16 +331,19 @@ build_gstgl = gstgl_dep.found() # FIXME: add option?
if build_gstgl
if gstgl_dep.type_name() == 'pkgconfig'
- gst_gl_winsys = gstgl_dep.get_pkgconfig_variable('gl_winsys')
- gst_gl_platforms = gstgl_dep.get_pkgconfig_variable('gl_platforms')
+ gst_gl_apis = gstgl_dep.get_pkgconfig_variable('gl_apis').split()
+ gst_gl_winsys = gstgl_dep.get_pkgconfig_variable('gl_winsys').split()
+ gst_gl_platforms = gstgl_dep.get_pkgconfig_variable('gl_platforms').split()
else
gstbase = subproject('gst-plugins-base')
- gst_gl_winsys = ' '.join(gstbase.get_variable('enabled_gl_winsys'))
- gst_gl_platforms = ' '.join(gstbase.get_variable('enabled_gl_platforms'))
+ gst_gl_apis = gstbase.get_variable('enabled_gl_apis')
+ gst_gl_winsys = gstbase.get_variable('enabled_gl_winsys')
+ gst_gl_platforms = gstbase.get_variable('enabled_gl_platforms')
endif
- message('GStreamer OpenGL window systems: ' + gst_gl_winsys)
- message('GStreamer OpenGL platforms: ' + gst_gl_platforms)
+ message('GStreamer OpenGL window systems: @0@'.format(' '.join(gst_gl_winsys)))
+ message('GStreamer OpenGL platforms: @0@'.format(' '.join(gst_gl_platforms)))
+ message('GStreamer OpenGL apis: @0@'.format(' '.join(gst_gl_apis)))
foreach ws : ['x11', 'wayland', 'android', 'cocoa', 'eagl', 'win32', 'dispmanx', 'viv_fb']
set_variable('gst_gl_have_window_@0@'.format(ws), gst_gl_winsys.contains(ws))
@@ -349,6 +352,10 @@ if build_gstgl
foreach p : ['glx', 'egl', 'cgl', 'eagl', 'wgl']
set_variable('gst_gl_have_platform_@0@'.format(p), gst_gl_platforms.contains(p))
endforeach
+
+ foreach api : ['opengl', 'gles2']
+ set_variable('gst_gl_have_api_@0@'.format(api), gst_gl_apis.contains(api))
+ endforeach
endif
libm = cc.find_library('m', required : false)