summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@centricular.com>2017-07-07 17:07:31 +0530
committerNirbheek Chauhan <nirbheek@centricular.com>2017-07-07 17:07:31 +0530
commit7e6a44388b832485722933627aebee2974269dd6 (patch)
tree413860f6c12ffccbc99ee9a426dbb334746f82a9 /meson.build
parentc360ceea4deb5d56c94126e31b9614734e8c1a7e (diff)
downloadgstreamer-plugins-bad-7e6a44388b832485722933627aebee2974269dd6.tar.gz
meson: Set python3 before plugin subdir()s
It's used by the msdk plugin
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index a1232c7b9..c14d6bf03 100644
--- a/meson.build
+++ b/meson.build
@@ -403,6 +403,8 @@ vs_module_defs_dir = meson.current_source_dir() + '/win32/common/'
# Used by the *_mkenum.py helper scripts
glib_mkenums = find_program('glib-mkenums')
+python3 = import('python3').find_python()
+
gir = find_program('g-ir-scanner', required : false)
gnome = import('gnome')
build_gir = gir.found() and not meson.is_cross_build() and not get_option('disable_introspection')
@@ -418,5 +420,4 @@ subdir('ext')
subdir('tests')
subdir('pkgconfig')
-python3 = import('python3').find_python()
run_command(python3, '-c', 'import shutil; shutil.copy("hooks/pre-commit.hook", ".git/hooks/pre-commit")')