summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorXavier Claessens <xavier.claessens@collabora.com>2018-04-24 14:05:30 -0400
committerTim-Philipp Müller <tim@centricular.com>2018-04-25 11:08:09 +0100
commit83d0623293770980184a0924192a47ed46011f8a (patch)
tree42069e90eaf5bcb8ce381f96a9ed0f12b092f708 /meson.build
parent87368e98b42bc83c47648938914cc3a08db9f80e (diff)
downloadgstreamer-plugins-bad-83d0623293770980184a0924192a47ed46011f8a.tar.gz
Meson: Generate pc file for all plugins in bad
https://bugzilla.gnome.org/show_bug.cgi?id=794568
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 3bf1ae88f..f68d08816 100644
--- a/meson.build
+++ b/meson.build
@@ -499,6 +499,14 @@ gir_init_section = [ '--add-init-section=extern void gst_init(gint*,gchar**);' +
'g_setenv("GST_PLUGIN_PATH_1_0", "", TRUE);' + \
'g_setenv("GST_PLUGIN_SYSTEM_PATH_1_0", "", TRUE);' + \
'gst_init(NULL,NULL);' ]
+
+pkgconfig = import('pkgconfig')
+plugins_pkgconfig_install_dir = join_paths(plugins_install_dir, 'pkgconfig')
+if get_option('default_library') == 'shared'
+ # If we don't build static plugins there is no need to generate pc files
+ plugins_pkgconfig_install_dir = disabler()
+endif
+
subdir('gst-libs')
subdir('gst')
subdir('sys')