summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2018-05-21 12:07:04 +0100
committerTim-Philipp Müller <tim@centricular.com>2018-05-21 12:07:04 +0100
commitb0404761f0ad6aa33086c79a4d63a6fdf3998d51 (patch)
tree3fafbcb75bb40f5175f56a472c700bf41a43a7f3 /meson.build
parent69fcd6391a5b2f32f9b0769d78eb860a4752e36a (diff)
downloadgstreamer-plugins-bad-b0404761f0ad6aa33086c79a4d63a6fdf3998d51.tar.gz
meson: add 'nls' option to disable translations
And enable by default. Was implicitly disabled because ENABLE_NLS was not defined.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index c4e5067c1..9c8f89484 100644
--- a/meson.build
+++ b/meson.build
@@ -272,6 +272,10 @@ cdata.set_quoted('GETTEXT_PACKAGE', 'gst-plugins-bad-1.0')
cdata.set_quoted('GST_API_VERSION', api_version)
cdata.set_quoted('GST_LICENSE', 'LGPL')
cdata.set_quoted('LIBDIR', join_paths(get_option('prefix'), get_option('libdir')))
+cdata.set_quoted('LOCALEDIR', join_paths(get_option('prefix'), get_option('localedir')))
+if get_option('nls')
+ cdata.set('ENABLE_NLS', 1)
+endif
warning_flags = [
'-Wmissing-declarations',
@@ -517,7 +521,7 @@ subdir('pkgconfig')
configure_file(output : 'config.h', configuration : cdata)
# xgettext is optional (on Windows for instance)
-if find_program('xgettext', required : false).found()
+if get_option('nls') and find_program('xgettext', required : false).found()
subdir('po')
endif