summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@centricular.com>2018-07-27 18:59:23 +0530
committerNirbheek Chauhan <nirbheek@centricular.com>2018-07-27 19:04:38 +0530
commitb55dfb5313f1df702a3637efbd372b90cd12a300 (patch)
treeae7f255314e783be74b9201cd6dfcd8ca9da18b5 /meson.build
parent7ef303fa281b9226ebd0087fb377ca25887941e4 (diff)
downloadgstreamer-plugins-bad-b55dfb5313f1df702a3637efbd372b90cd12a300.tar.gz
Add feature options for almost all plugins
The only plugins remaining are those that haven't been ported to Meson yet, and msdk. Also, the tests are still automagic. https://bugzilla.gnome.org/show_bug.cgi?id=795107
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build35
1 files changed, 8 insertions, 27 deletions
diff --git a/meson.build b/meson.build
index 9978f85fd..5f1c430be 100644
--- a/meson.build
+++ b/meson.build
@@ -387,11 +387,9 @@ endif
# GStreamer OpenGL
gstgl_dep = dependency('gstreamer-gl-1.0', version : gst_req,
- fallback : ['gst-plugins-base', 'gstgl_dep'], required: false)
+ fallback : ['gst-plugins-base', 'gstgl_dep'], required: get_option('gl'))
-build_gstgl = gstgl_dep.found() # FIXME: add option?
-
-if build_gstgl
+if gstgl_dep.found()
if gstgl_dep.type_name() == 'pkgconfig'
gst_gl_apis = gstgl_dep.get_pkgconfig_variable('gl_apis').split()
gst_gl_winsys = gstgl_dep.get_pkgconfig_variable('gl_winsys').split()
@@ -421,34 +419,17 @@ if build_gstgl
endif
libm = cc.find_library('m', required : false)
-glib_dep = dependency('glib-2.0', version : glib_req,
- fallback: ['glib', 'libglib_dep'])
-gmodule_dep = dependency('gmodule-2.0',
- fallback: ['glib', 'libgmodule_dep'])
-gio_dep = dependency('gio-2.0',
- fallback: ['glib', 'libgio_dep'])
-x11_dep = dependency('x11', required : false)
-
-# Used by dtls and hls
-openssl_dep = dependency('openssl', version : '>= 1.0.1', required : false)
-
-# Used by mpeg2enc and mplex
-# mjpegtools upstream breaks API constantly and doesn't export the version in
-# a header anywhere. The configure file has a lot of logic to support old
-# versions, but it all seems untested and broken. Require 2.0.0. Can be changed
-# if someone complains.
-mjpegtools_dep = dependency('mjpegtools', version : '>=2.0.0', required : false)
-mjpegtools_api = '0'
-if mjpegtools_dep.found()
- mjpegtools_api = '20000'
-endif
+glib_dep = dependency('glib-2.0', version : glib_req, fallback: ['glib', 'libglib_dep'])
+gmodule_dep = dependency('gmodule-2.0', fallback: ['glib', 'libgmodule_dep'])
+gio_dep = dependency('gio-2.0', fallback: ['glib', 'libgio_dep'])
+# gio-unix-2.0 is used by sys/bluez
+# Optional dep of ext/gl and gst/librfb
+x11_dep = dependency('x11', required : get_option('x11'))
if x11_dep.found()
cdata.set('HAVE_X11', 1)
endif
-mathlib = cc.find_library('m', required : false)
-
if host_machine.system() == 'windows'
winsock2 = [cc.find_library('ws2_32')]
else