summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMatthew Waters <matthew@centricular.com>2018-11-12 21:23:37 +1100
committerMatthew Waters <matthew@centricular.com>2018-11-12 21:37:07 +1100
commitc78f81f4105661b687ff496694b506deafe59312 (patch)
tree52b29ef80e7020106926335ac42a237cd889ec14 /meson.build
parent15fc39c2964c016ca29800e4637d486ee4af0497 (diff)
downloadgstreamer-plugins-bad-c78f81f4105661b687ff496694b506deafe59312.tar.gz
build: link against the gnustl dependency on android for c++ plugins
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 907abe836..9fd859d48 100644
--- a/meson.build
+++ b/meson.build
@@ -499,6 +499,11 @@ else
cdata.set('DISABLE_ORC', 1)
endif
+gnustl_dep = declare_dependency()
+if host_system == 'android'
+ gnustl_dep = dependency('gnustl', required : false)
+endif
+
if gst_dep.type_name() == 'internal'
gst_debug_disabled = not subproject('gstreamer').get_variable('gst_debug')
else