summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2017-12-26 13:52:18 +0100
committerTim-Philipp Müller <tim@centricular.com>2017-12-26 13:52:18 +0100
commitef557b5667df8793c2b1af66d96cce8337914bd2 (patch)
tree7d24f2fe4942f7a5674be30784e1925e70d89ce8 /meson.build
parent0ecac8f68adbc10447c772a99f215d2e7438fd02 (diff)
downloadgstreamer-plugins-bad-ef557b5667df8793c2b1af66d96cce8337914bd2.tar.gz
meson: skip translations if gettext is not available
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 4dca0ed54..4d57ccb14 100644
--- a/meson.build
+++ b/meson.build
@@ -461,6 +461,10 @@ subdir('sys')
subdir('ext')
subdir('tests')
subdir('pkgconfig')
-subdir('po')
+
+# xgettext is optional (on Windows for instance)
+if find_program('xgettext', required : false).found()
+ subdir('po')
+endif
run_command(python3, '-c', 'import shutil; shutil.copy("hooks/pre-commit.hook", ".git/hooks/pre-commit")')