summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@centricular.com>2018-08-17 02:59:26 +0530
committerNirbheek Chauhan <nirbheek@centricular.com>2018-08-17 04:07:24 +0530
commit5177f7c7ee583fc9e8582914a29694a40d781337 (patch)
tree9be16f30ab7063e9957df55dba704078a18dd59e /meson.build
parent5c462b9b12d4946c7d704bc7f19c50c9619caa24 (diff)
downloadgstreamer-plugins-bad-5177f7c7ee583fc9e8582914a29694a40d781337.tar.gz
meson: host_system is 'ios' when building for iOS
The cross file sets this value, and we use 'ios' in Cerbero.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 4 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 23e8fb272..71a28d066 100644
--- a/meson.build
+++ b/meson.build
@@ -332,9 +332,10 @@ cdata.set_quoted('GST_PACKAGE_ORIGIN', get_option('package-origin'))
host_system = host_machine.system()
if host_system == 'linux'
cdata.set_quoted('DEFAULT_VIDEOSRC', 'v4l2src')
-elif host_system == 'darwin'
+elif ['darwin', 'ios'].contains(host_system)
cdata.set_quoted('DEFAULT_VIDEOSRC', 'avfvideosrc')
cdata.set_quoted('GST_EXTRA_MODULE_SUFFIX', '.dylib')
+ # Yes, we set this for iOS too. Same as Autotools.
cdata.set('HAVE_OSX', 1)
else
cdata.set_quoted('DEFAULT_VIDEOSRC', 'videotestsrc')
@@ -429,10 +430,9 @@ else
winsock2 = []
endif
-if host_machine.system() == 'darwin'
+if ['darwin', 'ios'].contains(host_system)
add_languages('objc')
- mobilecoreservices_dep = dependency('MobileCoreServices', required : false)
- if mobilecoreservices_dep.found()
+ if host_system == 'ios'
cdata.set('HAVE_IOS', 1)
endif