summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAlessandro Decina <alessandro.d@gmail.com>2017-07-21 17:53:11 +1000
committerMatthew Waters <matthew@centricular.com>2018-08-03 12:51:28 +1000
commitc9226e6e804167836ce176c19ce63719c5b82822 (patch)
tree0f2d396fe8a39b579dc87cb6124794b22781026e /meson.build
parent760cbc4059c3726f61c83c26cf5efee58c5c3422 (diff)
downloadgstreamer-plugins-bad-c9226e6e804167836ce176c19ce63719c5b82822.tar.gz
meson: enable applemedia
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build26
1 files changed, 23 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index b2042e471..501ae60b8 100644
--- a/meson.build
+++ b/meson.build
@@ -113,7 +113,6 @@ check_functions = [
# check token HAVE_APPLE_MEDIA
# check token HAVE_ASSRENDER
# check token HAVE_AVC
-# check token HAVE_AVFOUNDATION
# check token HAVE_BLUEZ
# check token HAVE_BZ2
# check token HAVE_CFLOCALECOPYCURRENT
@@ -168,7 +167,6 @@ check_functions = [
# check token HAVE_GUDEV
# check token HAVE_HLS
# check token HAVE_ICONV
-# check token HAVE_IOS
# check token HAVE_JPEG
# check token HAVE_KATE
# check token HAVE_LADSPA
@@ -234,7 +232,6 @@ check_functions = [
# check token HAVE_VCD
# check token HAVE_VDPAU
# check token HAVE_VIDEOTOOLBOX
-# check token HAVE_VIDEOTOOLBOX_10_9_6
# check token HAVE_VOAACENC
# check token HAVE_VOAMRWBENC
# check token HAVE_WASAPI
@@ -434,6 +431,29 @@ else
winsock2 = []
endif
+if host_machine.system() == 'darwin'
+ add_languages('objc')
+ mobilecoreservices_dep = dependency('MobileCoreServices', required : false)
+ if mobilecoreservices_dep.found()
+ cdata.set('HAVE_IOS', 1)
+ endif
+
+ avfoundation_dep = dependency('AVFoundation', required : false)
+ if avfoundation_dep.found()
+ cdata.set('HAVE_AVFOUNDATION', 1)
+ endif
+
+ videotoolbox_dep = dependency('VideoToolbox', required : false)
+ if videotoolbox_dep.found()
+ cdata.set('HAVE_VIDEOTOOLBOX', 1)
+ endif
+
+# FIXME: framework.version() returns 'unknown'
+# if videotoolbox_dep.version().version_compare('>=10.9.6')
+# cdata.set('HAVE_VIDEOTOOLBOX_10_9_6', 1)
+# endif
+endif
+
have_orcc = false
orcc_args = []
# Used by various libraries/elements that use Orc code