summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@centricular.com>2018-08-31 14:37:46 +0530
committerNirbheek Chauhan <nirbheek@centricular.com>2018-08-31 14:41:00 +0530
commitcea5e3fcdb96deabd6cf6f7688de986a2512fdc3 (patch)
tree59ef5c0ea9aec770987dd6f9cbe79da4d99cfb0f /meson.build
parent515e2d765a63b60c3811efc7654b55df028c878a (diff)
downloadgstreamer-plugins-bad-cea5e3fcdb96deabd6cf6f7688de986a2512fdc3.tar.gz
meson: Maintain macOS ABI through dylib versioning
Requires Meson 0.48, but the feature will be ignored on older versions so it's safe to add it without bumping the requirement. Documentation: https://github.com/mesonbuild/meson/blob/master/docs/markdown/Reference-manual.md#shared_library
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 84dd85c37..78b7b1a49 100644
--- a/meson.build
+++ b/meson.build
@@ -23,7 +23,9 @@ api_version = '1.0'
soversion = 0
# maintaining compatibility with the previous libtool versioning
# current = minor * 100 + micro
-libversion = '@0@.@1@.0'.format(soversion, gst_version_minor * 100 + gst_version_micro)
+curversion = gst_version_minor * 100 + gst_version_micro
+libversion = '@0@.@1@.0'.format(soversion, curversion)
+osxversion = curversion + 1
plugins_install_dir = '@0@/gstreamer-1.0'.format(get_option('libdir'))