summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNicolas Dufresne <nicolas.dufresne@collabora.com>2018-08-02 11:19:07 -0400
committerNicolas Dufresne <nicolas.dufresne@collabora.com>2018-08-02 11:31:34 -0400
commitd2ee9b16fa7d4d3c2ded648a7606152209813a34 (patch)
tree8db3c434753e8850b87075660d7bdeb1393a74eb /meson.build
parent9c91282ba64d1750c9c1500b06f826d565ace859 (diff)
downloadgstreamer-plugins-bad-d2ee9b16fa7d4d3c2ded648a7606152209813a34.tar.gz
opencv: Fixup include to follow new standard
This uses the new path for OpenCV headers. OpenCV now have master headers files per modules, which reduce the amount of required includes. Note that HIGHGUI was included to get the imgcodecs includes, which I fixed, though the master header is missing the C headers, so I included that directly. All the image stuff should be ported to C++ eventually. Finally, this patch also update the header checks to reflect the modules that are really being used.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 0 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 5f1c430be..b2042e471 100644
--- a/meson.build
+++ b/meson.build
@@ -77,14 +77,12 @@ cdata = configuration_data()
check_headers = [
['HAVE_DLFCN_H', 'dlfcn.h'],
['HAVE_FCNTL_H', 'fcntl.h'],
- ['HAVE_HIGHGUI_H', 'highgui.h'],
['HAVE_INTTYPES_H', 'inttypes.h'],
['HAVE_MEMORY_H', 'memory.h'],
['HAVE_MSACM_H', 'msacm.h'],
['HAVE_NETINET_IN_H', 'netinet/in.h'],
['HAVE_NETINET_IP_H', 'netinet/ip.h'],
['HAVE_NETINET_TCP_H', 'netinet/tcp.h'],
- ['HAVE_OPENCV2_HIGHGUI_HIGHGUI_C_H', 'opencv2/highgui/highgui_c.h'],
['HAVE_PTHREAD_H', 'pthread.h'],
['HAVE_STDINT_H', 'stdint.h'],
['HAVE_STDLIB_H', 'stdlib.h'],