summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThibault Saunier <tsaunier@gnome.org>2016-08-24 09:41:08 -0300
committerThibault Saunier <tsaunier@gnome.org>2016-08-25 15:17:17 -0300
commit50473d77cc3e4c0e333978cede3bec10d9de1c3a (patch)
treef18df65870b47426445f00ba93a669c12d89d2af /meson.build
parent59b3e5944e5e573cf4e3e5607a7019f54f8d5eb6 (diff)
downloadgstreamer-plugins-bad-50473d77cc3e4c0e333978cede3bec10d9de1c3a.tar.gz
meson: Make mpegts lib build when using subprojects
The headers passed as parametter are relative to the build dir basically "../subproject/gst-plugins-bad/gst-libs/gst/mpegts/XXX.h" but that does not match what is needed at build time when building as subproject, also we always add current dir as include_dir so we are safe including directly. And link mpegtsdemux against the 'math' library as it is needed.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index a79b9129b..cb3bac899 100644
--- a/meson.build
+++ b/meson.build
@@ -305,6 +305,8 @@ if x11_dep.found()
cdata.set('HAVE_X11', 1)
endif
+mathlib = cc.find_library('m', required : false)
+
if host_machine.system() == 'windows'
winsock2 = [cc.find_library('ws2_32')]
else