summaryrefslogtreecommitdiff
path: root/pkgconfig/meson.build
diff options
context:
space:
mode:
authorMatthew Waters <matthew@centricular.com>2019-04-08 21:35:22 +1000
committerMatthew Waters <matthew@centricular.com>2019-06-04 09:03:44 +0000
commit25dd3b32e56f2acf8744baed6938fe701451ac8f (patch)
treef828e7d7ed2aa5af46d96875df5312e9e16aa10e /pkgconfig/meson.build
parent8def3b3743b5cd1f23da4a1e9abf27756d55fb7b (diff)
downloadgstreamer-plugins-bad-25dd3b32e56f2acf8744baed6938fe701451ac8f.tar.gz
vulkan: make a gstvulkan library out of the existing API
Diffstat (limited to 'pkgconfig/meson.build')
-rw-r--r--pkgconfig/meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/pkgconfig/meson.build b/pkgconfig/meson.build
index 7ddfafbbf..5bebe2f97 100644
--- a/pkgconfig/meson.build
+++ b/pkgconfig/meson.build
@@ -37,6 +37,11 @@ pkg_libs = [
# pkg_libs += 'wayland'
#endif
+if gstvulkan_dep.found()
+ pkgconf.set('vulkanlibdir', join_paths(meson.build_root(), gstvulkan.outdir()))
+ pkg_libs += 'vulkan'
+endif
+
foreach p : pkg_libs
infile = 'gstreamer-@0@.pc.in'.format(p)
outfile = 'gstreamer-@0@-@1@.pc'.format(p, api_version)