summaryrefslogtreecommitdiff
path: root/pkgconfig/meson.build
diff options
context:
space:
mode:
authorMatthew Waters <matthew@centricular.com>2020-08-11 21:56:39 +1000
committerGStreamer Merge Bot <gitlab-merge-bot@gstreamer-foundation.org>2020-08-15 02:55:30 +0000
commitbc95b5d99a844f590e04077a342f26ea877e2aad (patch)
tree3520e4ff7cc7d2bc8456676d39f972360cb46652 /pkgconfig/meson.build
parent314a8c023fe7f722821c73a1d06ebf6f62dd8806 (diff)
downloadgstreamer-plugins-bad-bc95b5d99a844f590e04077a342f26ea877e2aad.tar.gz
build/vulkan: split vulkan gir
also add to docs Part-of: <https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/merge_requests/1506>
Diffstat (limited to 'pkgconfig/meson.build')
-rw-r--r--pkgconfig/meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/pkgconfig/meson.build b/pkgconfig/meson.build
index 9e6c590fc..696f366f9 100644
--- a/pkgconfig/meson.build
+++ b/pkgconfig/meson.build
@@ -42,7 +42,15 @@ pkg_libs = [
if gstvulkan_dep.found()
pkgconf.set('vulkanlibdir', join_paths(meson.build_root(), gstvulkan.outdir()))
+ pkgconf.set('VULKAN_WINSYS', ' '.join(enabled_vulkan_winsys))
pkg_libs += 'vulkan'
+
+ if enabled_vulkan_winsys.contains('xcb')
+ pkg_libs += 'vulkan-xcb'
+ endif
+ if enabled_vulkan_winsys.contains('wayland')
+ pkg_libs += 'vulkan-wayland'
+ endif
endif
foreach p : pkg_libs