summaryrefslogtreecommitdiff
path: root/sys/Makefile.am
diff options
context:
space:
mode:
authorJoni Valtanen <joni.valtanen@movial.com>2009-07-29 15:35:03 +0200
committerSebastian Dröge <sebastian.droege@collabora.co.uk>2009-07-29 15:37:08 +0200
commitf41100e832c64f75fbe1f30e6db983fab7a2e6ee (patch)
tree8867250539e95be76a8e309be087be7f3aabcb19 /sys/Makefile.am
parent7fa5cba6f029aa89aa6f508f327aba9f6f8489f4 (diff)
downloadgstreamer-plugins-bad-f41100e832c64f75fbe1f30e6db983fab7a2e6ee.tar.gz
directsoundsrc: Add DirectSound source plugin
Fixes bug #344129.
Diffstat (limited to 'sys/Makefile.am')
-rw-r--r--sys/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/sys/Makefile.am b/sys/Makefile.am
index 15c89e179..5608a8e74 100644
--- a/sys/Makefile.am
+++ b/sys/Makefile.am
@@ -28,6 +28,12 @@ else
DIRECTDRAW_DIR=
endif
+if USE_DIRECTSOUND
+DIRECTSOUND_DIR=directsound
+else
+DIRECTSOUND_DIR=
+endif
+
if USE_FBDEV
FBDEV_DIR=fbdev
else
@@ -76,8 +82,8 @@ else
VDPAU_DIR=
endif
-SUBDIRS = $(ACM_DIR) $(DIRECTDRAW_DIR) $(DVB_DIR) $(FBDEV_DIR) $(OSS4_DIR) $(OSX_VIDEO_DIR) $(QT_DIR) $(VCD_DIR) $(VDPAU_DIR) $(WININET_DIR)
+SUBDIRS = $(ACM_DIR) $(DIRECTDRAW_DIR) $(DIRECTSOUND_DIR) $(DVB_DIR) $(FBDEV_DIR) $(OSS4_DIR) $(OSX_VIDEO_DIR) $(QT_DIR) $(VCD_DIR) $(VDPAU_DIR) $(WININET_DIR)
-DIST_SUBDIRS = acmenc acmmp3dec directdraw dvb fbdev dshowdecwrapper dshowsrcwrapper dshowvideosink \
+DIST_SUBDIRS = acmenc acmmp3dec directdraw directsound dvb fbdev dshowdecwrapper dshowsrcwrapper dshowvideosink \
oss4 osxvideo qtwrapper vcd vdpau wasapi wininet winks winscreencap