summaryrefslogtreecommitdiff
path: root/sys/Makefile.am
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2015-01-18 18:05:31 +0000
committerTim-Philipp Müller <tim@centricular.com>2015-01-24 20:28:16 +0000
commit199ce92474140ead718e416c971ddaf869d4e275 (patch)
treebdc26e537cb336c02d8e1eca5bd1296b1a2ed1e0 /sys/Makefile.am
parent6716671762e2fdf8adc282300cc7cbc0479081e0 (diff)
downloadgstreamer-plugins-bad-199ce92474140ead718e416c971ddaf869d4e275.tar.gz
Remove unported directdraw plugin
This API has been deprecated for eternities and microsoft stopped shipping the headers in 2010 accoding to wikipedia, so let's just remove it and focus on bringing the plugins based on the newer APIs up to snuff.
Diffstat (limited to 'sys/Makefile.am')
-rw-r--r--sys/Makefile.am10
1 files changed, 2 insertions, 8 deletions
diff --git a/sys/Makefile.am b/sys/Makefile.am
index fc21638cc..59496efe4 100644
--- a/sys/Makefile.am
+++ b/sys/Makefile.am
@@ -52,12 +52,6 @@ else
DECKLINK_DIR=
endif
-if USE_DIRECTDRAW
-DIRECTDRAW_DIR=directdraw
-else
-DIRECTDRAW_DIR=
-endif
-
if USE_WINKS
WINKS_DIR=winks
else
@@ -154,9 +148,9 @@ else
UVCH264_DIR=
endif
-SUBDIRS = $(ACM_DIR) $(ANDROID_MEDIA_DIR) $(APPLE_MEDIA_DIR) $(AVC_DIR) $(BLUEZ_DIR) $(D3DVIDEOSINK_DIR) $(DECKLINK_DIR) $(DIRECTDRAW_DIR) $(DIRECTSOUND_DIR) $(WINKS_DIR) $(DVB_DIR) $(FBDEV_DIR) $(LINSYS_DIR) $(OPENSLES_DIR) $(OSX_VIDEO_DIR) $(PVR_DIR) $(SHM_DIR) $(UVCH264_DIR) $(VCD_DIR) $(VDPAU_DIR) $(WININET_DIR) $(WINSCREENCAP_DIR) $(WASAPI_DIR)
+SUBDIRS = $(ACM_DIR) $(ANDROID_MEDIA_DIR) $(APPLE_MEDIA_DIR) $(AVC_DIR) $(BLUEZ_DIR) $(D3DVIDEOSINK_DIR) $(DECKLINK_DIR) $(DIRECTSOUND_DIR) $(WINKS_DIR) $(DVB_DIR) $(FBDEV_DIR) $(LINSYS_DIR) $(OPENSLES_DIR) $(OSX_VIDEO_DIR) $(PVR_DIR) $(SHM_DIR) $(UVCH264_DIR) $(VCD_DIR) $(VDPAU_DIR) $(WININET_DIR) $(WINSCREENCAP_DIR) $(WASAPI_DIR)
-DIST_SUBDIRS = acmenc acmmp3dec androidmedia applemedia applemedia-nonpublic avc bluez d3dvideosink decklink directdraw directsound dvb linsys fbdev dshowdecwrapper dshowsrcwrapper dshowvideosink \
+DIST_SUBDIRS = acmenc acmmp3dec androidmedia applemedia applemedia-nonpublic avc bluez d3dvideosink decklink directsound dvb linsys fbdev dshowdecwrapper dshowsrcwrapper dshowvideosink \
opensles osxvideo pvr2d shm uvch264 vcd vdpau wasapi wininet winks winscreencap
include $(top_srcdir)/common/parallel-subdirs.mak