summaryrefslogtreecommitdiff
path: root/sys/applemedia/Makefile.am
diff options
context:
space:
mode:
authorOle André Vadla Ravnås <oravnas@cisco.com>2010-11-04 14:14:09 +0100
committerOle André Vadla Ravnås <oravnas@cisco.com>2010-11-04 14:32:10 +0100
commit3ba76f825df1c72527a7c47f91fa0db0ed079c0b (patch)
tree47116e6fd6b4c27c568849a2c5f80b760a770b17 /sys/applemedia/Makefile.am
parent50c6e05924e88e758ba902d945cfa6cc7a59980a (diff)
downloadgstreamer-plugins-bad-3ba76f825df1c72527a7c47f91fa0db0ed079c0b.tar.gz
applemedia: add new iOS video source based on AVFoundation
This element makes use of the documented AVFoundation framework made available starting with iOS 4.0, and hence this means we can finally capture video using a public API.
Diffstat (limited to 'sys/applemedia/Makefile.am')
-rw-r--r--sys/applemedia/Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/sys/applemedia/Makefile.am b/sys/applemedia/Makefile.am
index f0f5288f2..0848e13dd 100644
--- a/sys/applemedia/Makefile.am
+++ b/sys/applemedia/Makefile.am
@@ -7,6 +7,7 @@ libgstapplemedia_la_SOURCES = \
vtenc.c \
vtdec.c \
vtutil.c \
+ bufferfactory.m \
corevideobuffer.c \
coremediabuffer.c \
coremediactx.c \
@@ -37,18 +38,21 @@ libgstapplemedia_la_LDFLAGS = \
$(GST_PLUGIN_LDFLAGS) \
$(GST_BASE_LDFLAGS) \
$(GST_PLUGINS_BASE_LDFLAGS) \
- -Wl,-framework -Wl,CoreFoundation
+ -Wl,-framework -Wl,CoreFoundation \
+ -Wl,-framework -Wl,CoreVideo
noinst_HEADERS = \
qtkitvideosrc.h \
miovideosrc.h \
miovideodevice.h \
+ avfvideosrc.h \
iphonecamerasrc.h \
vth264decbin.h \
vth264encbin.h \
vtenc.h \
vtdec.h \
vtutil.h \
+ bufferfactory.h \
corevideobuffer.h \
coremediabuffer.h \
coremediactx.h \
@@ -64,10 +68,16 @@ noinst_HEADERS = \
if HAVE_IOS
libgstapplemedia_la_SOURCES += \
+ avfvideosrc.m \
iphonecamerasrc.c \
mtapi.c \
celapi.c
+libgstapplemedia_la_LDFLAGS += \
+ -Wl,-framework -Wl,CoreMedia \
+ -Wl,-framework -Wl,Foundation \
+ -Wl,-framework -Wl,AVFoundation
+
else
libgstapplemedia_la_SOURCES += \
@@ -78,7 +88,6 @@ libgstapplemedia_la_SOURCES += \
libgstapplemedia_la_LDFLAGS += \
-Wl,-framework -Wl,Cocoa \
- -Wl,-framework -Wl,CoreVideo \
-Wl,-framework -Wl,QTKit
endif