summaryrefslogtreecommitdiff
path: root/sys/applemedia/Makefile.am
diff options
context:
space:
mode:
authorSebastian Dröge <sebastian@centricular.com>2016-08-30 16:21:25 +0300
committerSebastian Dröge <sebastian@centricular.com>2016-09-01 13:02:18 +0300
commite6b538402764a29351ffeecdbf2407ed8e7398a1 (patch)
treee966f65b7b76fba3c6915916e23a64f5cf893116 /sys/applemedia/Makefile.am
parent42f44f3fed2d86d45a47853847b466bccfacd619 (diff)
downloadgstreamer-plugins-bad-e6b538402764a29351ffeecdbf2407ed8e7398a1.tar.gz
applemedia: Conditionally compile qtkitvideosrc
The API was deprecated in 10.9 and apparently does not exist in the SDK for macOS Sierra anymore. https://bugzilla.gnome.org/show_bug.cgi?id=770587
Diffstat (limited to 'sys/applemedia/Makefile.am')
-rw-r--r--sys/applemedia/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/sys/applemedia/Makefile.am b/sys/applemedia/Makefile.am
index 4e415249d..f1e678558 100644
--- a/sys/applemedia/Makefile.am
+++ b/sys/applemedia/Makefile.am
@@ -92,16 +92,22 @@ libgstapplemedia_la_LDFLAGS += \
else
libgstapplemedia_la_SOURCES += \
- qtkitvideosrc.m \
iosurfacememory.c
libgstapplemedia_la_LDFLAGS += \
-Wl,-framework -Wl,Cocoa \
- -Wl,-framework -Wl,QTKit \
-Wl,-framework -Wl,IOSurface
endif
+if HAVE_QTKIT
+libgstapplemedia_la_SOURCES += \
+ qtkitvideosrc.m
+
+libgstapplemedia_la_LDFLAGS += \
+ -Wl,-framework -Wl,QTKit
+endif
+
if HAVE_AVFOUNDATION
libgstapplemedia_la_SOURCES += \