summaryrefslogtreecommitdiff
path: root/sys/d3dvideosink/Makefile.am
diff options
context:
space:
mode:
authorAndoni Morales Alastruey <ylatuya@gmail.com>2013-08-28 20:07:48 +0200
committerAndoni Morales Alastruey <ylatuya@gmail.com>2013-09-02 18:21:11 +0200
commitef7a8c2ca86590d994f6cf768070d75b05dd7b61 (patch)
tree929dd657b987a9cfec8cf12cca7d0dbd4af09cce /sys/d3dvideosink/Makefile.am
parent994739332d229a96fdc6bee9932d72349c29c614 (diff)
downloadgstreamer-plugins-bad-ef7a8c2ca86590d994f6cf768070d75b05dd7b61.tar.gz
d3dvideosink: disable buffer pools
On a device lost, all the surfaces allocated in the device need to be released before resetting the device, which can't be done for the allocated buffers. https://bugzilla.gnome.org/show_bug.cgi?id=706566
Diffstat (limited to 'sys/d3dvideosink/Makefile.am')
-rw-r--r--sys/d3dvideosink/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/sys/d3dvideosink/Makefile.am b/sys/d3dvideosink/Makefile.am
index b30c4dad1..986a00682 100644
--- a/sys/d3dvideosink/Makefile.am
+++ b/sys/d3dvideosink/Makefile.am
@@ -1,7 +1,8 @@
plugin_LTLIBRARIES = libgstd3dvideosink.la
libgstd3dvideosink_la_SOURCES = d3dvideosink.c d3dhelpers.c
-libgstd3dvideosink_la_CFLAGS = $(GST_PLUGINS_BAD_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS) $(GST_CFLAGS) $(DIRECT3D_CFLAGS) $(DIRECTX_CFLAGS)
+libgstd3dvideosink_la_CFLAGS = $(GST_PLUGINS_BAD_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS) $(GST_CFLAGS) $(DIRECT3D_CFLAGS) $(DIRECTX_CFLAGS) \
+ -DDISABLE_BUFFER_POOL
libgstd3dvideosink_la_LIBADD = $(GST_BASE_LIBS) $(GST_PLUGINS_BASE_LIBS) \
-lgstvideo-$(GST_API_VERSION) \
$(DIRECT3D_LIBS) $(DIRECTX_LDFAGS)