summaryrefslogtreecommitdiff
path: root/sys/d3dvideosink/Makefile.am
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2011-06-04 18:43:45 -0700
committerDavid Schleef <ds@schleef.org>2011-06-04 19:01:16 -0700
commit655e511a5c1704df907eaa62d6d9a6d32d2fd032 (patch)
tree383b246e0f5940e22e2e2f3f49f2730a4dd515d9 /sys/d3dvideosink/Makefile.am
parent7b12d4647a8a6a549143cdb6afa9294d1192efda (diff)
downloadgstreamer-plugins-bad-655e511a5c1704df907eaa62d6d9a6d32d2fd032.tar.gz
d3dvideosink: Add plugin
Fixes #651782. Patch from various authors, by way of ossbuild.
Diffstat (limited to 'sys/d3dvideosink/Makefile.am')
-rw-r--r--sys/d3dvideosink/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/sys/d3dvideosink/Makefile.am b/sys/d3dvideosink/Makefile.am
new file mode 100644
index 000000000..6e0ecf316
--- /dev/null
+++ b/sys/d3dvideosink/Makefile.am
@@ -0,0 +1,16 @@
+plugin_LTLIBRARIES = libgstd3dvideosink.la
+
+libgstd3dvideosink_la_SOURCES = d3dvideosink.c directx/d3d.c directx/dx.c \
+ directx/directx9/dx9.c directx/directx9/dx9_d3d.c \
+ directx/directx10/dx10.c directx/directx10/dx10_d3d.c \
+ directx/directx11/dx11.c directx/directx11/dx11_d3d.c
+libgstd3dvideosink_la_CFLAGS = $(GST_PLUGINS_BAD_CFLAGS) $(GST_CFLAGS)
+libgstd3dvideosink_la_LIBADD = $(GST_BASE_LIBS) $(GST_PLUGINS_BASE_LIBS) \
+ -lgstvideo-$(GST_MAJORMINOR) -lgstinterfaces-$(GST_MAJORMINOR)
+libgstd3dvideosink_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) -lgdi32
+libgstd3dvideosink_la_LIBTOOLFLAGS = --tag=disable-static
+
+noinst_HEADERS = d3dvideosink.h directx/d3d.h directx/dx.h directx/directx.h \
+ directx/directx9/dx9.h directx/directx9/dx9_d3d.h \
+ directx/directx10/dx10.h directx/directx10/dx10_d3d.h \
+ directx/directx11/dx11.h directx/directx11/dx11_d3d.h