summaryrefslogtreecommitdiff
path: root/sys/directsound/Makefile.am
diff options
context:
space:
mode:
authorРуслан Ижбулатов <lrn1986@gmail.com>2012-10-25 19:10:40 +0400
committerSebastian Dröge <sebastian.droege@collabora.co.uk>2012-10-26 10:01:03 +0200
commit0a30ecba90dbc8008ca0f9c39381f34f516e9190 (patch)
tree2bcb1163ac3c4167d2fa0640c1c8d5c4f12503c0 /sys/directsound/Makefile.am
parent0d1c7f6ea28b957c5df560208d88fa5cbb8beac0 (diff)
downloadgstreamer-plugins-bad-0a30ecba90dbc8008ca0f9c39381f34f516e9190.tar.gz
directsoundsrc: Fix a number of warnings/errors in directsoundsrc
* Don't use deprecated glib mutex functions * Don't declare useless variables * Don't link to non-existing libgstinterfaces Fixes #686871
Diffstat (limited to 'sys/directsound/Makefile.am')
-rw-r--r--sys/directsound/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/sys/directsound/Makefile.am b/sys/directsound/Makefile.am
index bdb48bd0f..c6b0e54b8 100644
--- a/sys/directsound/Makefile.am
+++ b/sys/directsound/Makefile.am
@@ -5,7 +5,7 @@ libgstdirectsoundsrc_la_CFLAGS = $(GST_CFLAGS) $(GST_BASE_CFLAGS) \
$(GST_PLUGINS_BASE_CFLAGS) $(DIRECTX_CFLAGS)
libgstdirectsoundsrc_la_LIBADD = $(DIRECTDRAW_LIBS) \
$(GST_BASE_LIBS) $(GST_PLUGINS_BASE_LIBS) -lgstaudio-$(GST_API_VERSION) \
- -lgstinterfaces-$(GST_API_VERSION) -ldsound
+ -ldsound
libgstdirectsoundsrc_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) $(DIRECTX_LDFLAGS)
libgstdirectsoundsrc_la_LIBTOOLFLAGS = --tag=disable-static