summaryrefslogtreecommitdiff
path: root/sys/directsound/Makefile.am
diff options
context:
space:
mode:
authorРуслан Ижбулатов <lrn1986@gmail.com>2009-08-26 01:18:00 +0100
committerTim-Philipp Müller <tim.muller@collabora.co.uk>2009-08-26 01:18:00 +0100
commit936d87f64b2d6cc66d689910dd5a8cbd3d63b055 (patch)
treec31eecc344fda4f2cdeccec157df9d945bf08b79 /sys/directsound/Makefile.am
parentf1c4bdf5be57c95defcbfe735c94664e0ec4db65 (diff)
downloadgstreamer-plugins-bad-936d87f64b2d6cc66d689910dd5a8cbd3d63b055.tar.gz
directdraw, directsound: unify CFLAGS and fix configure checks for DirectX-based plugins
One set of CFLAGS for all DirectX-based plugins. Correct header/library checks for DirectX-based-plugins. Remove unused variable and label in directsoundsrc. Fixes #593068.
Diffstat (limited to 'sys/directsound/Makefile.am')
-rw-r--r--sys/directsound/Makefile.am24
1 files changed, 12 insertions, 12 deletions
diff --git a/sys/directsound/Makefile.am b/sys/directsound/Makefile.am
index 319940148..cd1e05944 100644
--- a/sys/directsound/Makefile.am
+++ b/sys/directsound/Makefile.am
@@ -1,12 +1,12 @@
-plugin_LTLIBRARIES = libgstdirectsoundsrc.la
-
-libgstdirectsoundsrc_la_SOURCES = gstdirectsoundsrc.c gstdirectsoundplugin.c
-libgstdirectsoundsrc_la_CFLAGS = $(GST_CFLAGS) $(GST_BASE_CFLAGS) \
- $(GST_PLUGINS_BASE_CFLAGS)
-libgstdirectsoundsrc_la_LIBADD = $(DIRECTDRAW_LIBS) \
- $(GST_BASE_LIBS) $(GST_PLUGINS_BASE_LIBS) -lgstaudio-$(GST_MAJORMINOR) \
- -lgstinterfaces-$(GST_MAJORMINOR) -ldsound
-libgstdirectsoundsrc_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) $(DIRECTDRAW_LDFLAGS)
-libgstdirectsoundsrc_la_LIBTOOLFLAGS = --tag=disable-static
-
-noinst_HEADERS= gstdirectsoundsrc.h
+plugin_LTLIBRARIES = libgstdirectsoundsrc.la
+
+libgstdirectsoundsrc_la_SOURCES = gstdirectsoundsrc.c gstdirectsoundplugin.c
+libgstdirectsoundsrc_la_CFLAGS = $(GST_CFLAGS) $(GST_BASE_CFLAGS) \
+ $(GST_PLUGINS_BASE_CFLAGS) $(DIRECTX_CFLAGS)
+libgstdirectsoundsrc_la_LIBADD = $(DIRECTDRAW_LIBS) \
+ $(GST_BASE_LIBS) $(GST_PLUGINS_BASE_LIBS) -lgstaudio-$(GST_MAJORMINOR) \
+ -lgstinterfaces-$(GST_MAJORMINOR) -ldsound
+libgstdirectsoundsrc_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) $(DIRECTX_LDFLAGS)
+libgstdirectsoundsrc_la_LIBTOOLFLAGS = --tag=disable-static
+
+noinst_HEADERS= gstdirectsoundsrc.h