summaryrefslogtreecommitdiff
path: root/sys/msdk/Makefile.am
diff options
context:
space:
mode:
authorHyunjun Ko <zzoon@igalia.com>2018-02-13 13:44:08 -0900
committerSreerenj Balachandran <sreerenj.balachandran@intel.com>2018-02-13 13:44:08 -0900
commit2542b2d34da53f44b259780acba19907aab3e04d (patch)
tree07b35594317cb42536ed575576f16e2699a56207 /sys/msdk/Makefile.am
parent4d860ec82b7513e7b858b27f259098b4b6b31e3d (diff)
downloadgstreamer-plugins-bad-2542b2d34da53f44b259780acba19907aab3e04d.tar.gz
msdk: supports bufferpool
Implements 2 memory allocators: 1\ GstMsdkSystemAllocator: This will allocate system memory. 2\ GstMsdkVideoAllocator: This will allocate device memory depending on the platform. (eg. VASurface) Currently GstMsdkBufferPool uses video allocator currently by default only on linux. On Windows, we should use system memory until d3d allocator is implemented. https://bugzilla.gnome.org/show_bug.cgi?id=790752
Diffstat (limited to 'sys/msdk/Makefile.am')
-rw-r--r--sys/msdk/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/sys/msdk/Makefile.am b/sys/msdk/Makefile.am
index d968c7602..f0b22b2a2 100644
--- a/sys/msdk/Makefile.am
+++ b/sys/msdk/Makefile.am
@@ -2,6 +2,9 @@ plugin_LTLIBRARIES = libgstmsdk.la
libgstmsdk_la_SOURCES = \
gstmsdkcontext.c \
+ gstmsdksystemmemory.c \
+ gstmsdkvideomemory.c \
+ gstmsdkbufferpool.c \
gstmsdkh264dec.c \
gstmsdkh264enc.c \
gstmsdkh265dec.c \
@@ -22,6 +25,9 @@ nodist_EXTRA_libgstmsdk_la_SOURCES = not_present.cxx
noinst_HEADERS = \
msdk.h \
gstmsdkcontext.h \
+ gstmsdksystemmemory.h \
+ gstmsdkvideomemory.h \
+ gstmsdkbufferpool.h \
gstmsdkh264dec.h \
gstmsdkh264enc.h \
gstmsdkh265dec.h \