summaryrefslogtreecommitdiff
path: root/sys/nvcodec/meson.build
diff options
context:
space:
mode:
authorSeungha Yang <seungha@centricular.com>2020-04-16 23:27:31 +0900
committerGStreamer Merge Bot <gitlab-merge-bot@gstreamer-foundation.org>2020-04-24 09:23:10 +0000
commit9c21923f0451a88e81d0dc5b4cd6affdfc11a93d (patch)
tree2a4bea9d717794998e1040527a0f525aff772553 /sys/nvcodec/meson.build
parent62d1a3a14301f23d1b4538310be67e7aefee33dd (diff)
downloadgstreamer-plugins-bad-9c21923f0451a88e81d0dc5b4cd6affdfc11a93d.tar.gz
nvcodec: Add H264 stateless codec implementation
Introduce GstH264Decoder based Nvidia H.264 decoder element. Similar the element factory name of to v4l2 stateless codec, this element can be configured with factory name "gstnvh264sldec". Note that "sl" in the name stands for "stateless" For now, existing nvh264dec covers more profile and formats (e.g., interlaced stream) than this implementation. However, this implementation allows us to control lower level parameters such as decoded picture buffer management and therefore we can get a chance to improve performance in terms of latency. Part-of: <https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/merge_requests/1198>
Diffstat (limited to 'sys/nvcodec/meson.build')
-rw-r--r--sys/nvcodec/meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/sys/nvcodec/meson.build b/sys/nvcodec/meson.build
index b8d46f6f9..5a75e8129 100644
--- a/sys/nvcodec/meson.build
+++ b/sys/nvcodec/meson.build
@@ -9,6 +9,8 @@ nvcodec_sources = [
'gstcuvidloader.c',
'gstcudacontext.c',
'gstcudautils.c',
+ 'gstnvdecoder.c',
+ 'gstnvh264dec.c',
]
if get_option('nvcodec').disabled()
@@ -16,7 +18,7 @@ if get_option('nvcodec').disabled()
endif
plugin_incdirs = [configinc, include_directories('./stub')]
-extra_c_args = []
+extra_c_args = ['-DGST_USE_UNSTABLE_API']
if gstgl_dep.found()
extra_c_args += ['-DHAVE_NVCODEC_GST_GL=1']
@@ -26,7 +28,7 @@ gstnvcodec = library('gstnvcodec',
nvcodec_sources,
c_args : gst_plugins_bad_args + extra_c_args,
include_directories : plugin_incdirs,
- dependencies : [gstbase_dep, gstvideo_dep, gstpbutils_dep, gstgl_dep, gmodule_dep],
+ dependencies : [gstbase_dep, gstvideo_dep, gstpbutils_dep, gstgl_dep, gmodule_dep, gstcodecs_dep],
install : true,
install_dir : plugins_install_dir,
)