summaryrefslogtreecommitdiff
path: root/sys/vdpau/Makefile.am
diff options
context:
space:
mode:
authorCarl-Anton Ingmarsson <ca.ingmarsson@gmail.com>2010-06-09 15:43:43 +0200
committerCarl-Anton Ingmarsson <ca.ingmarsson@gmail.com>2010-06-23 21:51:53 +0200
commit0490cb89c67ef173ce3d68f14fbedb87e2788181 (patch)
tree2569f38942e02dd9bec04c8241ffc140b923b78a /sys/vdpau/Makefile.am
parent4926c6c617416228882c4382d286f38bc34eee45 (diff)
downloadgstreamer-plugins-bad-0490cb89c67ef173ce3d68f14fbedb87e2788181.tar.gz
vdpau: base vdpaumpegdec on GstBaseVideoDecoder
Diffstat (limited to 'sys/vdpau/Makefile.am')
-rw-r--r--sys/vdpau/Makefile.am60
1 files changed, 21 insertions, 39 deletions
diff --git a/sys/vdpau/Makefile.am b/sys/vdpau/Makefile.am
index a96f1c3af..10e552c2f 100644
--- a/sys/vdpau/Makefile.am
+++ b/sys/vdpau/Makefile.am
@@ -1,53 +1,35 @@
+SUBDIRS = basevideodecoder gstvdp
+
plugin_LTLIBRARIES = libgstvdpau.la
libgstvdpau_la_SOURCES = \
- gstvdpmpegdec.c \
- mpegutil.c \
gstvdpau.c \
gstvdpvideopostprocess.c \
- gstvdpsink.c
+ gstvdpsink.c \
+ mpeg/gstvdpmpegframe.c \
+ mpeg/mpegutil.c \
+ mpeg/gstvdpmpegdec.c \
+ h264/gstnalreader.c \
+ h264/gsth264parser.c \
+ h264/gstvdph264dec.c
libgstvdpau_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_CFLAGS) $(X11_CFLAGS) $(VDPAU_CFLAGS)
+
libgstvdpau_la_LIBADD = $(GST_LIBS) $(GST_BASE_LIBS) \
$(GST_PLUGINS_BASE_LIBS) $(X11_LIBS) -lgstvideo-$(GST_MAJORMINOR) \
- -lgstinterfaces-$(GST_MAJORMINOR) $(VDPAU_LIBS) libgstvdp-@GST_MAJORMINOR@.la
+ -lgstinterfaces-$(GST_MAJORMINOR) $(VDPAU_LIBS) \
+ basevideodecoder/libgstbasevideodecoder.la \
+ gstvdp/libgstvdp-@GST_MAJORMINOR@.la
+
libgstvdpau_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
libgstvdpau_la_LIBTOOLFLAGS = --tag=disable-static
noinst_HEADERS = \
- gstvdpmpegdec.h \
- mpegutil.h \
- gstvdputils.h \
gstvdpvideopostprocess.h \
- gstvdpsink.h
-
-lib_LTLIBRARIES = libgstvdp-@GST_MAJORMINOR@.la
-
-libgstvdp_@GST_MAJORMINOR@_la_SOURCES = \
- gstvdpdevice.c \
- gstvdputils.c \
- gstvdpvideobuffer.c \
- gstvdpoutputbuffer.c \
- gstvdpvideosrcpad.c \
- gstvdpoutputsrcpad.c \
- gstvdp.c
-
-libgstvdp_@GST_MAJORMINOR@includedir = $(includedir)/gstreamer-@GST_MAJORMINOR@/gst/vdpau
-libgstvdp_@GST_MAJORMINOR@include_HEADERS = \
- gstvdpdevice.h \
- gstvdpvideobuffer.h \
- gstvdpoutputbuffer.h \
- gstvdpvideosrcpad.h \
- gstvdpoutputsrcpad.h \
- gstvdp.h
-
-libgstvdp_@GST_MAJORMINOR@_la_CFLAGS = $(GST_CFLAGS) $(GST_BASE_CFLAGS) \
- $(GST_PLUGINS_BASE_CFLAGS) $(X11_CFLAGS) $(VDPAU_CFLAGS)
-
-libgstvdp_@GST_MAJORMINOR@_la_LIBADD = $(GST_LIBS) $(X11_LIBS) $(VDPAU_LIBS) \
- -lgstvideo-$(GST_MAJORMINOR)
-
-libgstvdp_@GST_MAJORMINOR@_la_LDFLAGS = $(GST_LIB_LDFLAGS) $(GST_LT_LDFLAGS) $(GST_ALL_LDFLAGS)
-libgstvdp_@GST_MAJORMINOR@_la_LIBTOOLFLAGS = --tag=disable-static
-
-
+ gstvdpsink.h \
+ mpeg/gstvdpmpegframe.h \
+ mpeg/mpegutil.h \
+ mpeg/gstvdpmpegdec.h \
+ h264/gstnalreader.h \
+ h264/gsth264parser.h \
+ h264/gstvdph264dec.h \ No newline at end of file