summaryrefslogtreecommitdiff
path: root/tests/check/Makefile.am
diff options
context:
space:
mode:
authorMatthew Waters <matthew@centricular.com>2015-06-10 16:36:15 +1000
committerMatthew Waters <matthew@centricular.com>2015-06-12 16:59:20 +1000
commit7d8d1f8206cc5303309f8951e863b20e8fd905d0 (patch)
tree6c966dd7c0d5d7d26aceb6338a7457195d41086b /tests/check/Makefile.am
parent6e88b07cc5c4ef2ad439815d0ca8b20f7a8a3c6a (diff)
downloadgstreamer-plugins-bad-7d8d1f8206cc5303309f8951e863b20e8fd905d0.tar.gz
glmemory: implement on top of glbasebuffer
Provides convenient access to PBO usage. Currently texture updates are coupled tightly to data transfers.
Diffstat (limited to 'tests/check/Makefile.am')
-rw-r--r--tests/check/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/tests/check/Makefile.am b/tests/check/Makefile.am
index 295791b77..da8df716e 100644
--- a/tests/check/Makefile.am
+++ b/tests/check/Makefile.am
@@ -203,6 +203,7 @@ endif
if USE_GL
check_gl=libs/gstglcontext \
+ libs/gstglbuffer \
libs/gstglmemory \
libs/gstglupload \
libs/gstglcolorconvert \
@@ -489,6 +490,16 @@ libs_gstglmemory_CFLAGS = \
-DGST_USE_UNSTABLE_API \
$(GST_BASE_CFLAGS) $(GST_CFLAGS) $(AM_CFLAGS)
+libs_gstglbuffer_LDADD = \
+ $(top_builddir)/gst-libs/gst/gl/libgstgl-@GST_API_VERSION@.la \
+ $(GST_PLUGINS_BASE_LIBS) -lgstvideo-$(GST_API_VERSION) \
+ $(GST_BASE_LIBS) $(GST_LIBS) $(LDADD)
+
+libs_gstglbuffer_CFLAGS = \
+ $(GST_PLUGINS_BAD_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS) \
+ -DGST_USE_UNSTABLE_API \
+ $(GST_BASE_CFLAGS) $(GST_CFLAGS) $(AM_CFLAGS)
+
libs_gstglupload_CFLAGS = \
$(GST_PLUGINS_BAD_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS) \
-DGST_USE_UNSTABLE_API \