summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1281839c7..3e9ed79d0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -263,7 +263,8 @@ GST_PLUGINS_SELECTED=""
AC_ARG_WITH(plugins,
AC_HELP_STRING([--with-plugins],[comma-separated list of plug-ins to compile]),
[for i in `echo $withval | tr , ' '`; do
- if test -n `echo $i | grep $GST_PLUGINS_ALL`; then
+ if echo $GST_PLUGINS_ALL | grep $i > /dev/null
+ then
GST_PLUGINS_SELECTED="$GST_PLUGINS_SELECTED $i"
else
echo "plug-in $i not recognized, ignoring..."