summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4ad07ad18..4240006d2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -922,6 +922,9 @@ if test "x$USE_ATOMIC_H" = xyes; then
AC_DEFINE(HAVE_ATOMIC_H, 1, [Define if atomic.h header file is available])
fi
+# do not use deprecated stuff
+GST_CFLAGS="$GST_CFLAGS -DGST_DISABLE_DEPRECATED"
+
if test "x$USE_DEBUG" = xyes; then
GST_CFLAGS="$GST_CFLAGS -g"
fi